Use forceUpdate=true for Homematic bindings in OH2


how can I set forceUpdate=true for Homematic items in OH2 in my .items file? Could not find any working sample. The only way I can set forceUpdate to true is via Paper UI, but I would like to config this via the .items file.


Me too.

forceUpdate has been removed from the binding:

Can you explain a bit more in detail why you think you need this function?

I’m wondering why I can set forceUpdate in the Paper UI. But I don’t really know that I need it. I was migrating my old oh1 items. And they had it set. I got the definitions from an example back then.

I used forceUpdate for HM-Dis-EP-WM55 e-paper switch & display and I think it is really needed here.

The display has 4 channels: 1 & 2 are used for the button press events and 3 to update the display. The problem / challenge is, if a button was pressed the display content is reset to it is initial state. So whatever was send to the display on channel 3 before is gone now. To me it looks like the display resets itself after each button press, might be a firmware issue, but at the moment it is default behavior.

Channel 3 item definition of the display looks like:

String Switch_GF_Floor_1_Display        "Alarmschalter Flur EG Display"                         <wallswitch>  (gHouse)                                {channel="homematic:HG-HM-Dis-EP-WM55:ccu:NEQ0721334:3#SUBMIT"}

I used forceUpdate on channel 3 to resend the text of the display via a short rule after each button press to workaround the display reset. The value of the display content variable was resend to the device, even it has not changed in OpenHab.

So I think for this case forceUpdate is still needed.

I did not test the latest Homematic add-on version. But there have been lots of changes. So maybe it works now correctly without this option.

I think @gerrieg can help you better

It was available in the OH2 release version and has been removed in a later version.

forceUpdate has been removed after OH2 release, the binding uses now ‘forceUpdate=true’ by default. Use the latest snapshot version and it will work

Thanks. Will give it a try, if forceUpdate=true now is the default behavior it should work.