Use latest zwave database with zwave-2.4.0

I have a device which is in the current zwave database. I want to stay with the 2.4.0 zwave binding, because the 2.5.0-SNAPSHOT is instable. (Serial port was detected by binding, but stopped working after reboot)
I also have to manually add the xtream module.
Where can I download the 2.4.0 zwave binding with the latest zwave database?

You cannot do that because the database is part of the binding. You CAN run the latest z-wave binding on OpenHAB 2.4
Is that what you wish to do? Your original request is a little garbled.

If so, the easiest way to do that is to run the upgrade script with OpenHAB running.

It occurs to me, the latest zwave database is not part of the latest 2.4.0 binding. You are right, unfortunately the database is part of the binding.
They are currently working on the 2.5.0 version of the binding, so I assume device added to the database will only be added to the 2.5.0. Version of the binding.
This version is not stable yet, so I want to use the 2.4.0 binding with an up-to-date database

The zwave binding is stable as far as I know. I nave been running 2.5M2 for quite a while. Other parts of OpenHAB are not necessarily stable in the latest snapshot. I have heard of no such issues with the zwave binding.
For one thing the developer does not even have his development environment working so he could change the binding in a major fashion. The main changes with a newer binding, since 2.5M1, is the database. there was some work before 2.5M1 and the binding now has an additional dependency. That is why I recommend using the script.

If you upgrade the binding & have issues, Chris & Scott will be the first to reach out and help.

You also have the option of recompiling the 2.4 binding with the new database but be warned this is not for noobs. I will try to find the post and provide a link if I can

Anyhow, how long ago did you try the 2.5 snapshot because I’m almost certain both the issues you are talking about (serial port and having to add xtream module) have been fixed in latest snapshots and people are reporting the latest zwave snapshot runs on 2.4

Depending on the device that you want to support, this may not work since there may be code changes to support specific database features that may be used in some devices.


I downloaded the 2.5.0 snapshot at 15-9-2019. What version of xstream can I use best?
I was using 2.4.0 placed in the addons directory. Is it enough to remove 2.4.0 and install 2.5.0 and xstream?
I have some Neo coolcam PIRs which are recognized as wrong device in 2.4.0 and according the database as PD03Z (258 0003:108D). Do I have to exlude and include again to change to the correct device?
By the way, I’m using OpenHAB 2.4.0.

No Just delete & rediscover the Thing. It will have the same node ID information.but get rediscovered by the binding.

The manual instructions are in the README accompanying the script

1 Like

Thanks all for your help. I finally managed to get 2.5.0 working.
I used the script to install the zwave binding. Unfortunately my SNORT IDS blocked downloading the zwave jar. The file was partially downloaded.
After I solved that problem, the zwave controller was still not found.
I stopped OpenHAB and cleared the cache, then I started OpenHAB again.
After that zwave functioned again.


You may want to delete your Z-Wave Things and rediscover them. They will keep the same IDs (Items and rules will not break) but may benefit from any database changes since 2.4.