Using a Fortrezz flow meter (new device)


I have a FortrezZ flow meter ( plugged in and connected to openhab. It sees it as an unknown device; 0084:0473:0110:1.16.

I checked and don’t see the flow meter there, so I think it needs a new entry. I think I’m supposed to post here and @chris can modify the database?

Sorry if this isn’t the right process – I’m new to openhab and adding z-wave devices. What other information can I give to help?


Oh, it looks like FortrezZ wrote some code for SmartThings if that helps: github /fortrezz/smartthings/tree/master/flow%20meter%20(fmi)

Edit: breaking the last link because it won’t let me post something with 3 links…

@clouserw The process for adding a new device is described here.

The quickest way to get started with adding the device is to upload the node.xml file found in the userdata/zwave directory. This file is created by the binding as part of the initialization process.

You’ll then need to add the configuration parameters and association groups for the device (usually found in the device manual).

Chris usually updates the binding every 2-3 days.

Please post back here with any questions.

Thanks! I created an account and opened a ticket for edit permissions. Cheers


May I ask you where you found it, and if the device now is working correctly with OH?


I just got the device off their website.

It’s in the database now, but I didn’t see any directions on how to use the new database. Is there documentation on updating the database in openhab? Thanks!

The database is packaged with the zwave binding. @chris does a binding release every few days to pick up the database changes. Once the new binding is built, you need to install it. How you install it depends on whether you’re running snapshot, milestone, or release builds.

I installed the release version of openhabian. I found some instructions to switch to the snapshot builds, but is it possible to run a snapshot z-wave binding with a release openhabian? If that’s not recommended I can switch to snapshot versions. Thanks for the advice!

Over time, inconsistencies/incompatibilities will develop between a recent version of a binding and the core framework in the release build. If you’re running the 2.3 release, which is quite old at this point, there may be issues installing the zwave binding from the current snapshot.

You’re probably ok installing a snapshot build. The builds are pretty stable right now, as we’re nearing the release of 2.4.

If you decide to install a recent snapshot build, please be aware that there were major changes to the zwave binding, as described here.

@clouserw I’ve already migrated my OH to the new one (openhabian). The best thing to do is remove all zwave things and re-do from scratch the zwave part. Istructions in the link above.

I upgraded to snapshot builds of openhabian which brought along the 2.4.0.SNAPSHOT z-wave binding and the updated database.

It does recognize the device now, which is great, although I’m not sure it’s working as expected. I haven’t used this device either, so I’m going off of the product description and forum posts over on smartthings. Some observations so far:

  1. This has 8 channels by default. I haven’t looked at the 3 alarms and the battery level, which leaves 4 other channels:
  • Sensor (temperature): This one looks like it works correctly. I’ve been getting reasonable numbers off of it all day.
  • Binary Sensor: This is a Switch. I’m assuming it’s a yes/no for water flowing. I never saw it change values, despite running water.
  • Sensor (general): This is a Number. I’m not really sure what it’s for, but it’s been reporting 0.0 all day. I’m guessing it’s supposed to be Gallons per Minute. It never changed value, despite running water.
  • Water meter (amps): This is a Number and increases as water flows. I don’t know what the (amps) is in the default name. A mistake?

I think the way water meters work is that you’re supposed to reset the count periodically (eg. daily), and then you can track daily water usage. I reset this to 0 by writing to one of the parameters via the REST API. This water meter tracks a total lifetime water usage via the dials on the actual device, but I don’t think it’s a part of the z-wave reporting.

So, the temperature and total seem to work, the GPM and on/off doesn’t, from what I can tell. I didn’t test the alarms or battery levels.

hi, are you still using this meter? are you satisfied? did you ever get GPM counter working?
Have you tried switching that switch from ON to OFF (by sending it OFF command from openhab)?
I understand from product description it has a valve to shut off water. so in theory, if you switch that switch to off your water should stop flowing…

I am still using it. Everything works fine, although, caveat, I switched to using Home Assistant a few years ago and am using it with Z-wave JS.

My meter doesn’t have an on/off valve in it. Maybe there is a newer model that does at this point. Cheers

oh, good to hear its working good.

I don’t think they have a new model, maybe it doesn’t have the valve, but then the product description is deceiving

under features:

  • Automatically turn off water if TOO MUCH water is flowing
  • Automatically turn off water is water has been running for TOO LONG

maybe they mean, (if you buy our automatic shut off valve) then automatically turn off water :slight_smile:
there should be a disclaimer