Hello all,

I believe I have set up my MQTT correctly, here are the steps I followed.

  1. SSH into openHABian
  2. Ran the config tool
  3. Added Mosquitto from the additional components
  4. Restarted mosquitto service and openhab2 service and check for errors
  5. Reboot machine
  6. Within PaperUI I made sure to add the MQTT binding
  7. I configured the binding as such and also configured my iusername and password within paperui as well. (openhabian) and the password provided during installation

Now I expected to be able to add the broker to my “things” but when I did, it seems i get this error in the ui and I can’t find much about it. “UNINITIALIZED - HANDLER_INITIALIZING_ERROR”

The stack trace I see in the logs is:
2020-05-08 18:13:51.390 [ERROR] [core.thing.internal.ThingManagerImpl] - Exception occurred while initializing handler of thing ‘mqtt:broker:a7533eb9’:[Ljavax/net/ssl/TrustManager;)V
at org.openhab.binding.mqtt.handler.BrokerHandler.assignSSLContextProvider( ~[?:?]
at org.openhab.binding.mqtt.handler.BrokerHandler.initialize( ~[?:?]
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) ~[?:?]
at sun.reflect.NativeMethodAccessorImpl.invoke( ~[?:?]
at sun.reflect.DelegatingMethodAccessorImpl.invoke( ~[?:?]
at java.lang.reflect.Method.invoke( ~[?:?]
at org.eclipse.smarthome.core.internal.common.AbstractInvocationHandler.invokeDirect( [137:org.openhab.core:]
at [137:org.openhab.core:]
at [?:?]
at java.util.concurrent.ThreadPoolExecutor.runWorker( [?:?]
at java.util.concurrent.ThreadPoolExecutor$ [?:?]
at [?:?]

For me it helped to change the IP address to from to
The address of the Raspberry

Thanks for the idea. I just tried that, restarted the openhab2 service and still no luck.

Install MQTT explorer on your PC and see if you can connect to the MQTT server.
If you know that is working you can check OH

Looks as though I was able to connect with no problem.

Did you use a password to connect to your MQTT broker?
Best is to use the IP address like in the MQTT explorer
Make sure that the username and password are correct.

PaperUI shows both the username and password filled in and I even re-pasted the password to be sure.

Did you add the MQTT Broker Moquette in Paper UI?

I did not have that installed. I have installed it now, where should I configure it?

Uh, I think they were asking because you don’t want to have Moquette installed as well, you have a perfectly fine broker already in Mosquitto.

Your error message is all about SSL, if you wanted that you’d have to set up certificates and things that you haven’t mentioned.
But why would want SSL on a localhost link?

I don’t want SSL at all. I have it configured to not use SSL as you can see in my first post? Or is there something additional I need to edit?

Yes indeed. Yet that’s the error message.
If you try connecting to some non-existent broker with or without SSL, log messages are quite different.
Maybe something messed up - I would first try setting SSL on and saving, then setting off and saving.

Sure you have only one broker Thing?

Ok I tried what you said but so far no change. This is a screenshot of all my things. I only have one broker thing and one thing that is supposed to use that broker.

I tested today that using external clients I am able to connect (without ssl) and pub sub some random topic. This definitely seems to be something weird with the broker I’m using within openhab. Does the fact that I’m in snapshot mode matter? Currently using 2.5.0 Snapshot of the broker add-on