Using network:pingdevice in docker

I’m running OH 2.5.1 in a docker environment on an Ubuntu server.

I haven’t been able to make the network:pingdevice work, pinging an external host (

arping is present in the container: -rwsr-xr-x 1 root root 39648 Dec 28 2018 /usr/sbin/arping* and I have configured the network bindig to allow system pings and I’ve specified the arp utility path.

It doesn’t seem to work though. Any ideas where to look? It should work, shouldn’t it?

Are you using --net=host?

I’ve only ever used the Network binding to ping local devices, not external devices. But I just added one and it seems to work for me. And just to make sure, I installed iputils-ping in the container and ran it from a shell and it worked as well.

I’ve not tried to do anything with arping so can’t help with any of that.

1 Like

Yes I do.

I ran out of ideas and I was impatient so I found and installed a small python script that does what I want. openHAB gets the internet status from MQTT now which is great.

Thanks @rlkoshak, you are always helpful.

1 Like