Using openHAB designer on Windows with openHAB on Linux

I just installed openHAB 1.7 on a Beagle Bone Black running Ubuntu 14.04. I tried the demo and it works fine. I tried to edit the items and sitemap files with vi and ran into problems. I needed openHAB designer but there is not much space left on the Beagle Bone Black SSD so I figured that I could install the Windows version and select a configuration folder over the network.
I tried selecting /etc/openhab and got “The chosen directory is not a valid openHAB configuration directory.”. I tried /etc/openHAB/configurations and got the same error. Anybody got this working?

I use it this way and it works just fine, So you have the folder mounted correctly on your windows machine? The designer should point to /etc/openhab/configurations/ just to clarify.
My next thought would be permissions, your windows user may not have permissions to read the files in that directory.
This is how my samba share is setup

[openhab] path = /etc/openhab/ available = yes read only = no browseable = yes public = no writeable = yes create mask=0777 directory mask=0777 only guests=no

Thanks! Just knowing that it should work just fine is a big help. Also knowing that the configuration directory is /etc/openhab/configurations helps.
I checked my permissions as you suggested and found that I did not have write access. I now have read/write access to /etc/openhab and everything below including the directories. But … still the same error.
I have done some playing with the demo setup. I might be missing some essential file or have some too many. Here is the directory listing of my configuraions folder and subfolders. Anything wrong?

items openhab.cfg persistence rules scripts sitemaps transform


db4o.persist exec.persist logging.persist rrd4j.persist





[quote=“ygrignon, post:3, topic:4687, full:true”]

items openhab.cfg persistence rules scripts sitemaps transform[/quote]

In order for the openhab designer to realize the correct configuration folder you also need to have the openhab_default.cfg file into that folder.

Thanks sihui! I did as you suggested and tried to open /etc/openhab/configurations but no luck. Then I tried /etc/openhab and bingo it worked :grinning:
But then nothing happened. What is supposed to happen? The open configuration window closed and the main screen did not change. It would be nice if there was some sort of manual for this designer program. I am an old school guy and I like to read a manual. I find that all of openHAB is guesswork. But it is so adaptable and nice that I will struggle through it.

Progress! I put openhab_default.cfg in configurations/ and I see a list of directories. I think that I am good to go from here.
Thanks again to you two gentlemen, you were a great help.

[quote=“ygrignon, post:5, topic:4687, full:true”]
I find that all of openHAB is guesswork.[/quote]

Not really, but you have to do a DEEP look into the search engines of the web :grinning:

For the designer, take a look here, that’s all you will need to use it.

Good luck.

[quote=“batfasturd, post:2, topic:4687, full:true”]
This is how my samba share is setup[/quote]

Thx for sharing this. Until now I used public=yes, yours is much better and more secure!

Glad I could help, I think I found that on the interwebs a while back while configuring my samba share.

I didn’t want to set up Samba, so I used on my Windows box.

This is handy!

just that there must be something about write-permissions (runtime runs on raspberry and login is standard)
how did you fix this?

Hi all,

I realise this is a bit of an old thread, but is OpenHAB defunct?

I am starting to user Openhav Designer on windows and having the same problem. The following thread seems to suggest it has something to do with Java version being 32bits or 64bits.

Please someone help. Thx.