Using openHabian for the first time

I have installed openHAB 2 onto a Raspberry Pi 3 Model B running Debian. Some questions;

  1. Connecting to the Pi using a monitor/HDMI cable. How do I restore the ability to connect using SSH?

  2. How do I access the Pi GUI?

  3. What is the next step to accessing the openHAB service?

Thanks for any help.

Installing and accessing:

http://docs.openhab.org/installation/rasppi.html
http://docs.openhab.org/installation/openhabian.html
http://docs.openhab.org/installation/linux.html

Note: I think that raspbian now comes with ssh disabled so you may need to connect a monitor/keyboard/mouse to the Pi and run raspiconfig to enable it.

Accessing OH once it is installed and getting started:

http://docs.openhab.org/tutorials/beginner/

That is true about raspbian and ssh but there is a solution.

For headless setup, SSH can be enabled by placing a file named ‘ssh’, without any extension, onto the boot partition of the SD card.

Thanks Daniel. I have absolutely no idea how to do that!

Thanks Rich. I think installing openHabian has been a step back for me as I seem to have lost more than I’ve gained so far!

Literally putting the sd card in another computer and creating a file called “ssh” in the boot partition (most likely the only bit of the sd card you can see from Windows).

Well. The only file name containing the word “boot” is called “bootcode.bin” which I cannot open. :expressionless:

The folder that the “bootcode.bin” is located in is called the boot partition. You just need to create another file called “ssh” (without a file extension) in the same folder that “bootcode.bin” lives in.

Thank you again, but no idea how to do that! :confounded:

Assuming Windows all you do is:

  • plug the SD card into the machine
  • browse to the SD card. You will only be able to access the boot partition
  • right click and select “New File”
  • name the file “ssh”
  • eject the SD card
  • plug it into your Raspberry Pi
  • turn on the pi
  • wait for the pi to boot

You should now have ssh enabled.

Whilst Raspberry Pi says that it had been disabled since December 2016, when using the Openhabian image on a Raspberry Pi 3, SSH has always been enabled.

I’ve never had to enable SSH, including a fresh install 2 hours ago.

Surely every install should be exactly the same?

That’s worrying me as well! I wonder what else didn’t work? :confounded:

Thanks. I opened the SD card using windows but it only gives me the option of creating a new folder. Will this work as well? And I now have the added concern, posed by Michael, that ssh should be there already. In fact in the installation process it also says that it should be available :cold_sweat:

Are you using raspbian/debian as per your initial post or are you using openHABian?

I’ve tried to install openHABian, but the Pi doesn’t accept ssh as it should, and I cannot make any progress. So the Pi currently has an unknown bit of OpenHABian I guess. Maybe the best approach now would be to try and reinstall it, but I can’t find any instructions on how to go about that or how to connect using ssh.

I suggest you start again by rewriting your micro sd card with the Openhabian image. Instructions are here:
http://docs.openhab.org/installation/openhabian.html#raspberry-pi

Also suggest you connect a monitor to the HDMI port so you can watch the progress of the install. When the main installation finishes it will show the login prompt. At that point you should be able to SSH (PuTTY) to it.

You need to wait a bit longer for Openhab to install itself.

Thanks, the second time around it has installed - monitoring progress really helped and I had no problems starting PuTTY and logging in from a laptop. Now contemplating where to go from here…