Using Sigma ACC-UBZ2-U with OpenHAB2.0 with Raspberry Pi3

Hi, I have successfully Installed OpenHAB2.0 on Pi3 just by following setup guide and it’s Active, working fine.

I have Sigma ACC-UZB2-U Z-Wave USB static controller & for binding it I am giving port Address as /dev/ttyACM0 under binding configuration. but all the time it is giving me communication error.

can anyone help me to bind controller with Rpi3??

Hi Sihui,

Thanks for the response. I have a dought that do I need to use any USB to serial convertor or I am good with just z wave USB static controller and just need to find correct address??
Also do I need to modify any files in order to enable serial communication on USB port ??

Yes, that is all you need.

That is normally not necessary, just perform the steps to connect to the zwave controller:

and add the openhab user to the dialout and tty group:

If you are using openHABian you can do that via openHABian config menu.

1 Like

Hi Sihui,

Thanks for the help but on pi3 I am able to run only basic UI whenever I am trying to install Standard or Advanced UI it keeps on loading with message “Be standby it may take several minutes” I used to wait for more than an hour but still not getting anything. when looking at log files it says error installing UI.

in my setup I used to follow below steps:

  1. Installing Zulu Embedded 32 bit as per recommendations and making it default java.
  2. Following Linux installation steps & once installation of stable release done I am about proceed further but always stuck at UI installation but for basic UI it works fine then I am adding OpenHAB as a user & giving it all privileges as per recommendation. and while adding Sigma ACC-UBZ2-U stick it says offline.

is it something that it won’t be configured without Openhabmin??

if you are running it with Sigma stick and on pi3 can you provide me your all steps??

I followed the installation tutorial step by step, that worked for me.

I cannot follow exactly where you are stucked now … if you were able to set up a working openHAB follow these commands to find out your interface (which needs to be added as a thing through PaperUI or preferrable HABmin when dealing with zwave devices):

dmesg -T | grep tty