Uuid and secret?

Tags: #<Tag:0x00007efecc77ccf8>

Hello I’m trying to set up openhab cloud since a few days. Unfortunately I fail to find the uuid and the secret. When I try to open a folder, access is denied. I do this through putty and I tried to do it once on the pi. I haven’t changed the passwords and usernames yet, is that possible?

Try /var/lib/openhab2 to find uuid and /var/lib/openhab2/openhabcloud for secret. Be aware you habe to install the binding first.

2 Likes

You are using openhabian, so you can easily access to the files from your (windows) Remote-computer:
uuid:
\\openhab\openHAB-share\openhab2-userdata
secret:
\\openhab\openHAB-share\openhab2-userdata\openhabcloud

Open the files with a texteditor and you find the keys.

seems not to be correct. Because of the errors you did not see the file you were looking for.
secret file was found and is listed.

To prevent such cases you either need to run the command with higher privileges:

sudo find . -name secret

as long as the user you are logged in with is allowed to run sudo command.

What you also could do is to redirect the error messages to /dev/null

sudo find . -name secret 2>/dev/null

But you need to be aware that error messages are not shown and the command dies not look into those directories then.

thanks do you men the openhab cloud conector

Yes the openhab cloud connector in paperUI > addons > Misc.

Yes

@Wolfgang_S,Dibbler42,Tuny,H102

Thanks for your Help my error was that I forget “sudo nano”.
Now it works and I am Happy ; ).

What is only not open yet is the connection from localhost to myopenhab but thanks again you have already helped me a lot.

Greetings Malte

You may mark the related post as solution and

open a new question for this one.