Vallox SE Binding

I will test that tomorrow with a fresh openhab 3.1 with only your vallox 3.1 binding test and give a response

Hi Miika,
Today I tested various new openHAB 3.1 instances. With all 3.1 versions, whether M4 or snapshot, the binding does not start (see log).

2021-05-21 06:54:08.437 [WARN ] [org.apache.felix.fileinstall ] - Error while starting bundle: file:/C:/Temp/openHAB/openhab-3.1.0-SNAPSHOT/addons/org.openhab.binding.vallox-3.1.0-SNAPSHOT.jar
org.osgi.framework.BundleException: Could not resolve module: org.openhab.binding.vallox [235]
Unresolved requirement: Import-Package: org.openhab.core.io.transport.serial

at org.eclipse.osgi.container.Module.start(Module.java:463) ~[org.eclipse.osgi-3.16.200.jar:?]
at org.eclipse.osgi.internal.framework.EquinoxBundle.start(EquinoxBundle.java:440) ~[org.eclipse.osgi-3.16.200.jar:?]
at org.apache.felix.fileinstall.internal.DirectoryWatcher.startBundle(DirectoryWatcher.java:1260) [bundleFile:3.6.8]
at org.apache.felix.fileinstall.internal.DirectoryWatcher.startBundles(DirectoryWatcher.java:1233) [bundleFile:3.6.8]
at org.apache.felix.fileinstall.internal.DirectoryWatcher.doProcess(DirectoryWatcher.java:520) [bundleFile:3.6.8]
at org.apache.felix.fileinstall.internal.DirectoryWatcher.process(DirectoryWatcher.java:365) [bundleFile:3.6.8]
at org.apache.felix.fileinstall.internal.DirectoryWatcher.run(DirectoryWatcher.java:316) [bundleFile:3.6.8]

You sure you have serial transport feature installed?

feature:install openhab-transport-serial

And please see my github for updated version including a dependency fix for snapshot version.

Yes I did that, then I get this error:

2021-05-30 11:04:04.067 [ERROR] [Events.Framework                    ] - FrameworkEvent ERROR
org.osgi.framework.BundleException: Could not resolve module: org.openhab.binding.vallox [235]
  Unresolved requirement: Import-Package: org.apache.commons.io; version="[2.2.0,3.0.0)"

	at org.eclipse.osgi.container.Module.start(Module.java:463) ~[org.eclipse.osgi-3.16.200.jar:?]
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel$2.run(ModuleContainer.java:1845) ~[org.eclipse.osgi-3.16.200.jar:?]
	at org.eclipse.osgi.internal.framework.EquinoxContainerAdaptor$1$1.execute(EquinoxContainerAdaptor.java:136) ~[org.eclipse.osgi-3.16.200.jar:?]
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1838) ~[org.eclipse.osgi-3.16.200.jar:?]
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1781) ~[org.eclipse.osgi-3.16.200.jar:?]
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1743) ~[org.eclipse.osgi-3.16.200.jar:?]
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1665) ~[org.eclipse.osgi-3.16.200.jar:?]
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1) ~[org.eclipse.osgi-3.16.200.jar:?]
	at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:234) [org.eclipse.osgi-3.16.200.jar:?]
	at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:345) [org.eclipse.osgi-3.16.200.jar:?]
2021-05-30 11:04:04.513 [INFO ] [ab.ui.habpanel.internal.HABPanelTile] - Started HABPanel at /habpanel
2021-05-30 11:04:10.865 [INFO ] [e.automation.internal.RuleEngineImpl] - Rule engine started.

Hello with the newest version I got the following error (3.1.0.M4 - Milestone Build):

2021-05-31 10:58:30.387 [WARN ] [org.apache.felix.fileinstall        ] - Error while starting bundle: file:/usr/share/openhab/addons/org.openhab.binding.vallox-3.1.0-SNAPSHOT.jar
org.osgi.framework.BundleException: Could not resolve module: org.openhab.binding.vallox [232]
  Unresolved requirement: Import-Package: javax.measure; version="[2.1.0,3.0.0)"
	at org.eclipse.osgi.container.Module.start(Module.java:463) ~[org.eclipse.osgi-3.16.200.jar:?]
	at org.eclipse.osgi.internal.framework.EquinoxBundle.start(EquinoxBundle.java:440) ~[org.eclipse.osgi-3.16.200.jar:?]
	at org.apache.felix.fileinstall.internal.DirectoryWatcher.startBundle(DirectoryWatcher.java:1260) [bundleFile:3.6.8]
	at org.apache.felix.fileinstall.internal.DirectoryWatcher.startBundles(DirectoryWatcher.java:1233) [bundleFile:3.6.8]
	at org.apache.felix.fileinstall.internal.DirectoryWatcher.startAllBundles(DirectoryWatcher.java:1221) [bundleFile:3.6.8]
	at org.apache.felix.fileinstall.internal.DirectoryWatcher.doProcess(DirectoryWatcher.java:515) [bundleFile:3.6.8]
	at org.apache.felix.fileinstall.internal.DirectoryWatcher.process(DirectoryWatcher.java:365) [bundleFile:3.6.8]
	at org.apache.felix.fileinstall.internal.DirectoryWatcher.run(DirectoryWatcher.java:316) [bundleFile:3.6.8]

try M5

Hello with the newest version I got the following error (3.1.0.M5 - Milestone Build):

2021-05-31 14:32:49.443 [WARN ] [org.apache.felix.fileinstall        ] - Error while starting bundle: file:/usr/share/openhab/addons/org.openhab.binding.sony-3.1.0-alpha.andan-SNAPSHOT.jar
org.osgi.framework.BundleException: Could not resolve module: org.openhab.binding.sony [235]
  Unresolved requirement: Import-Package: javax.measure; version="[1.0.0,2.0.0)"
	at org.eclipse.osgi.container.Module.start(Module.java:463) ~[org.eclipse.osgi-3.16.200.jar:?]
	at org.eclipse.osgi.internal.framework.EquinoxBundle.start(EquinoxBundle.java:440) ~[org.eclipse.osgi-3.16.200.jar:?]
	at org.apache.felix.fileinstall.internal.DirectoryWatcher.startBundle(DirectoryWatcher.java:1260) [bundleFile:3.6.8]
	at org.apache.felix.fileinstall.internal.DirectoryWatcher.startBundles(DirectoryWatcher.java:1233) [bundleFile:3.6.8]
	at org.apache.felix.fileinstall.internal.DirectoryWatcher.startAllBundles(DirectoryWatcher.java:1221) [bundleFile:3.6.8]
	at org.apache.felix.fileinstall.internal.DirectoryWatcher.doProcess(DirectoryWatcher.java:515) [bundleFile:3.6.8]
	at org.apache.felix.fileinstall.internal.DirectoryWatcher.process(DirectoryWatcher.java:365) [bundleFile:3.6.8]
	at org.apache.felix.fileinstall.internal.DirectoryWatcher.run(DirectoryWatcher.java:316) [bundleFile:3.6.8]

Oh right I forgot it’s a jar compiled on 3.0
OSGi dependencies have changed so it needs to be recompiled on 3.1M4 or newer (@gitMiguel).

Thanks guys for the info, specially @mstormi .I did a rebase last weekend but then it seems that it’s not new enough. Hopefully I can get it fixed in a few upcoming days.

Any news here?

Yes. Errors are now fixed and I’ve uploaded new .jar.

I tried the jar from https://github.com/gitMiguel/openhab-addons/tree/main/bundles/org.openhab.binding.vallox on OH 3.1 but failed, when I move the jar into the addons folder I’m getting

@gitMiguel Miika would you mind compiling a jar for 3.1 ?

2021-08-11 01:25:38.385 [WARN ] [org.apache.felix.fileinstall        ] - Error while starting bundle: file:/usr/share/openhab/addons/org.openhab.binding.vallox-3.1.0-SNAPSHOT.jar
org.osgi.framework.BundleException: Could not resolve module: org.openhab.binding.vallox [285]
  Unresolved requirement: Import-Package: javax.measure; version="[1.0.0,2.0.0)"

        at org.eclipse.osgi.container.Module.start(Module.java:463) ~[org.eclipse.osgi-3.16.200.jar:?]
        at org.eclipse.osgi.internal.framework.EquinoxBundle.start(EquinoxBundle.java:440) ~[org.eclipse.osgi-3.16.200.jar:?]
        at org.apache.felix.fileinstall.internal.DirectoryWatcher.startBundle(DirectoryWatcher.java:1260) [bundleFile:3.6.8]
        at org.apache.felix.fileinstall.internal.DirectoryWatcher.startBundles(DirectoryWatcher.java:1233) [bundleFile:3.6.8]
        at org.apache.felix.fileinstall.internal.DirectoryWatcher.doProcess(DirectoryWatcher.java:520) [bundleFile:3.6.8]
        at org.apache.felix.fileinstall.internal.DirectoryWatcher.process(DirectoryWatcher.java:365) [bundleFile:3.6.8]
        at org.apache.felix.fileinstall.internal.DirectoryWatcher.run(DirectoryWatcher.java:316) [bundleFile:3.6.8]

I have it working I think… cannot validate as the unit is very remote in fact :wink: but at least I’m getting temperatures and fan speed shown.
To be frank I’m a little disappointed in the available channels … I have no own SE and I’m coming from a MV unit and the valloxmv binding, and there’s quite some more parameters.
Is there any docs on channels/unit parameters ? Fan speed seems to be more or less the only useful parameter you can control. I’m guessing you can set it to 1-8, and that that’ll translate into fixed rpm on the SE unit - is that correct ?

I can confirm the current binding seems to be working under 3.1 with a 510 SE unit, using a $2 USB interface.

You can find a channel list in the readme: openhab-addons/README.md at main · gitMiguel/openhab-addons · GitHub. It more or less follows vallox’s protocol definition and channels found there.

Indeed some of the available channels are a bit useless along with the control panel having way too small buttons.

There are settings accessible with the control panel where you set the actual speed (0-100%) for every of those steps (1-8). Another two settings can also be found where you can adjust the fans separately from 0-100% (I think originally these two settings are only meant for stabilizing the air volume between input and output depending on building charateristics).

One possibility is to set the speed always on maximum for every step so it runs always at 100%. Then you command channels fanControl#dcFanOutputAdjustment and fanControl#dcFanInputAdjustment (these are the same two mentioned above) to more precisely adjust the fan speeds. But remember to keep those balanced so your building won’t go too much overpressure/underpressure.

Problem with manual installation of the binding „vallox-3.3.0-SNAPSHOT.jar“ on the Openhab 3.2 system.
Actual status:
I´m running the the Openhab 3.1 with the Binding „vallox-3.1.0-SNAPSHOT.jar“ on a RaspberryPi4. It works fine. I remember that I copied the Binding „vallox-3.1.0-SNAPSHOT.jar“ in the addons folder. After that the binding appears as a thing.
Now I updated to Openhab 3.2. After the update the Vallox binding is „uninizialized“ and the only option I have is to remove the complete binding.
To validate the situation I setup a new Openhab 3.2 version on the RaspberryPi4. I copied the binding „vallox-3.3.0-SNAPSHOT.jar“ in the addons folder but nothing happens.
Can somebody help me what I need to do next step by step? I already read some posts how to modify the „addons.cfg“ file and typed some commands in the Karaf but without luck.

Hi, @GB19, and welcome to the forum!

I’m dealing with the same problem but haven’t resolved it yet.

openhab> bundle:restart 235
Error executing command: Error restarting bundles:
        Unable to start bundle 235: Could not resolve module: org.openhab.binding.vallox [235]
  Unresolved requirement: Import-Package: javax.measure; version="[1.0.0,2.0.0)"

I’ll see what i can do.

Edit #1
Just tried binding version

274 │ Active  │  80 │ 3.3.0.202112281002    │ openHAB Add-ons :: Bundles :: Vallox Binding

with oh build

runtimeInfo:
  version: 3.2.0
  buildString: Release Build

and works fine.

I think there’s no need no modify any files etc. Are you sure you have only one .jar file in the addons folder? What does

bundle:list

output when typed in karaf console?

IMO first thing to do in these kind of problems is to see the logs and bundle info from karaf. To help view the logs I use frontail.

Hi gitMiguel,
I´m studying this forum since years and it brings you forward. Thanks for your afford!
Result from „bundle:list“:
It seems that the ID251 ist the Vallox binding. The Version fits. But the name “Vallox” at the end is missing.

openhab> bundle:list | grep Vallox
openhab> bundle:list
START LEVEL 100 , List Threshold: 50
 ID │ State     │ Lvl │ Version               │ Name
────┼───────────┼─────┼───────────────────────┼────────────────────────────────
 29 │ Active    │  80 │ 2.12.5                │ Jackson-annotations
 30 │ Active    │  80 │ 2.12.5                │ Jackson-core
 31 │ Active    │  80 │ 2.12.5                │ jackson-databind
 32 │ Active    │  80 │ 2.12.5                │ Jackson-dataformat-YAML
 33 │ Active    │  80 │ 2.12.5                │ Jackson datatype: JSR310
 34 │ Active    │  80 │ 6.2.6                 │ Woodstox
 35 │ Active    │  80 │ 2.8.6                 │ Gson
 36 │ Active    │  80 │ 27.1.0.jre            │ Guava: Google Core Libraries f
 37 │ Active    │  80 │ 30.1.0.jre            │ Guava: Google Core Libraries f
 38 │ Active    │  80 │ 1.0.1                 │ Guava InternalFutureFailureAcc
 39 │ Active    │  80 │ 3.0.0.v201312141243   │ Google Guice (No AOP)
 41 │ Active    │  80 │ 4.8.35.v20190528-1517 │ ClassGraph
 42 │ Active    │  80 │ 2.1.9                 │ swagger-annotations
 43 │ Active    │  80 │ 2.1.9                 │ swagger-core
 44 │ Active    │  80 │ 2.1.9                 │ swagger-integration
 45 │ Active    │  80 │ 2.1.9                 │ swagger-jaxrs2
 46 │ Active    │  80 │ 2.1.9                 │ swagger-models
 47 │ Active    │  80 │ 2.0.2                 │ Jakarta Bean Validation API
 49 │ Active    │  80 │ 2.3.3                 │ Jakarta XML Web Services API
 52 │ Active    │  80 │ 3.5.7                 │ JmDNS
 53 │ Active    │  80 │ 2.1.3                 │ Units of Measurement API
 55 │ Active    │  80 │ 0.5.10                │ Jollyday
 56 │ Active    │  80 │ 3.2.0.v201101311130   │ ANTLR Runtime
 57 │ Active    │  80 │ 1.2.2                 │ org.apache.aries.component-dsl
 58 │ Active    │  80 │ 1.0.1                 │ Apache Aries JAX-RS Specificat
 59 │ Active    │  80 │ 2.0.0                 │ Apache Aries JAX-RS Whiteboard
 61 │ Active    │  80 │ 3.12.0                │ Apache Commons Lang
 62 │ Active    │  80 │ 3.4.5                 │ Apache CXF Core
 63 │ Active    │  80 │ 3.4.5                 │ Apache CXF Runtime JAX-RS Fron
 64 │ Active    │  80 │ 3.4.5                 │ Apache CXF JAX-RS Client
 65 │ Active    │  80 │ 3.4.5                 │ Apache CXF JAX-RS Server-Side
 66 │ Active    │  80 │ 3.4.5                 │ Apache CXF Runtime Security fu
 67 │ Active    │  80 │ 3.4.5                 │ Apache CXF Runtime HTTP Transp
 76 │ Active    │  80 │ 4.3.4                 │ Apache Karaf :: OSGi Services
 87 │ Active    │  80 │ 1.0.0.2               │ Apache ServiceMix :: Bundles :
 95 │ Active    │  80 │ 2.2.5                 │ XmlSchema Core
 96 │ Active    │  80 │ 4.20.0                │ Apache XBean :: OSGI Bundle Ut
 97 │ Active    │  80 │ 4.20.0                │ Apache XBean :: Classpath Reso
 98 │ Active    │  80 │ 0.7.7                 │ jose4j
 99 │ Active    │  80 │ 2.17.0.v20190920-0401 │ EMF Common
100 │ Active    │  80 │ 2.20.0.v20190920-0401 │ EMF Ecore
101 │ Active    │  80 │ 2.14.0.v20190528-0725 │ EMF Change Model
102 │ Active    │  80 │ 2.16.0.v20190528-0725 │ EMF XML/XMI Persistence
103 │ Active    │  80 │ 3.13.0.v20200828-1034 │ Common Eclipse Runtime
132 │ Active    │  80 │ 0.10.0.v20201105-1103 │ org.eclipse.lsp4j
133 │ Active    │  80 │ 0.10.0.v20201105-1103 │ org.eclipse.lsp4j.jsonrpc
134 │ Active    │  80 │ 2.25.0.v20210301-0821 │ Xtend Runtime Library
135 │ Active    │  80 │ 2.25.0.v20210301-0821 │ Xtend Macro Interfaces
136 │ Active    │  80 │ 2.25.0.v20210301-0843 │ Xtext
137 │ Active    │  80 │ 2.25.0.v20210301-0909 │ Xtext Common Types
138 │ Active    │  80 │ 2.25.0.v20210301-0843 │ Xtext IDE Core
139 │ Active    │  80 │ 2.25.0.v20210301-0843 │ Xtext Utility
140 │ Active    │  80 │ 2.25.0.v20210301-0909 │ Xbase Model
141 │ Active    │  80 │ 2.25.0.v20210301-0909 │ Xbase Generic IDE Services
142 │ Active    │  80 │ 2.25.0.v20210301-0821 │ Xbase Runtime Library
146 │ Active    │  80 │ 9.2.0                 │ org.objectweb.asm
147 │ Active    │  80 │ 9.2.0                 │ org.objectweb.asm.commons
148 │ Active    │  80 │ 9.2.0                 │ org.objectweb.asm.tree
149 │ Active    │  80 │ 9.2.0                 │ org.objectweb.asm.tree.analysis
150 │ Active    │  80 │ 9.2.0                 │ org.objectweb.asm.util
151 │ Active    │  80 │ 3.2.0                 │ openHAB Core :: Bundles :: Core
152 │ Active    │  80 │ 3.2.0                 │ openHAB Core :: Bundles :: Mar
153 │ Active    │  80 │ 3.2.0                 │ openHAB Core :: Bundles :: Com
154 │ Active    │  80 │ 3.2.0                 │ openHAB Core :: Bundles :: Aud
155 │ Active    │  80 │ 3.2.0                 │ openHAB Core :: Bundles :: JAA
156 │ Active    │  80 │ 3.2.0                 │ openHAB Core :: Bundles :: OAu
157 │ Active    │  80 │ 3.2.0                 │ openHAB Core :: Bundles :: Aut
158 │ Active    │  80 │ 3.2.0                 │ openHAB Core :: Bundles :: Aut
159 │ Active    │  80 │ 3.2.0                 │ openHAB Core :: Bundles :: Aut
160 │ Active    │  80 │ 3.2.0                 │ openHAB Core :: Bundles :: Aut
161 │ Active    │  80 │ 3.2.0                 │ openHAB Core :: Bundles :: Aut
162 │ Active    │  80 │ 3.2.0                 │ openHAB Core :: Bundles :: Bin
163 │ Active    │  80 │ 3.2.0                 │ openHAB Core :: Bundles :: Con
164 │ Active    │  80 │ 3.2.0                 │ openHAB Core :: Bundles :: Con
165 │ Active    │  80 │ 3.2.0                 │ openHAB Core :: Bundles :: Con
166 │ Active    │  80 │ 3.2.0                 │ openHAB Core :: Bundles :: Con
167 │ Active    │  75 │ 3.2.0                 │ openHAB Core :: Bundles :: Con
168 │ Active    │  80 │ 3.2.0                 │ openHAB Core :: Bundles :: Eph
169 │ Active    │  80 │ 3.2.0                 │ openHAB Core :: Bundles :: ID
170 │ Active    │  80 │ 3.2.0                 │ openHAB Core :: Bundles :: Con
171 │ Active    │  80 │ 3.2.0                 │ openHAB Core :: Bundles :: Con
172 │ Active    │  80 │ 3.2.0                 │ openHAB Core :: Bundles :: HTT
173 │ Active    │  80 │ 3.2.0                 │ openHAB Core :: Bundles :: HTT
175 │ Active    │  80 │ 3.2.0                 │ openHAB Core :: Bundles :: Mon
176 │ Active    │  80 │ 3.2.0                 │ openHAB Core :: Bundles :: Net
177 │ Active    │  80 │ 3.2.0                 │ openHAB Core :: Bundles :: RES
178 │ Active    │  80 │ 3.2.0                 │ openHAB Core :: Bundles :: Aud
179 │ Active    │  80 │ 3.2.0                 │ openHAB Core :: Bundles :: Aut
180 │ Active    │  80 │ 3.2.0                 │ openHAB Core :: Bundles :: RES
181 │ Active    │  80 │ 3.2.0                 │ openHAB Core :: Bundles :: RES
182 │ Active    │  80 │ 3.2.0                 │ openHAB Core :: Bundles :: Sit
183 │ Active    │  80 │ 3.2.0                 │ openHAB Core :: Bundles :: SSE
184 │ Active    │  80 │ 3.2.0                 │ openHAB Core :: Bundles :: RES
185 │ Active    │  80 │ 3.2.0                 │ openHAB Core :: Bundles :: UI
186 │ Active    │  80 │ 3.2.0                 │ openHAB Core :: Bundles :: Voi
187 │ Active    │  80 │ 3.2.0                 │ openHAB Core :: Bundles :: mDN
188 │ Active    │  80 │ 3.2.0                 │ openHAB Core :: Bundles :: Kar
189 │ Active    │  80 │ 3.2.0                 │ openHAB Core :: Bundles :: Mod
190 │ Active    │  80 │ 3.2.0                 │ openHAB Core :: Bundles :: Mod
191 │ Active    │  80 │ 3.2.0                 │ openHAB Core :: Bundles :: Mod
192 │ Active    │  80 │ 3.2.0                 │ openHAB Core :: Bundles :: Mod
193 │ Active    │  80 │ 3.2.0                 │ openHAB Core :: Bundles :: Lan
194 │ Active    │  80 │ 3.2.0                 │ openHAB Core :: Bundles :: Mod
195 │ Active    │  80 │ 3.2.0                 │ openHAB Core :: Bundles :: Mod
196 │ Active    │  80 │ 3.2.0                 │ openHAB Core :: Bundles :: Mod
197 │ Active    │  80 │ 3.2.0                 │ openHAB Core :: Bundles :: Mod
198 │ Active    │  80 │ 3.2.0                 │ openHAB Core :: Bundles :: Mod
199 │ Active    │  80 │ 3.2.0                 │ openHAB Core :: Bundles :: Mod
200 │ Active    │  80 │ 3.2.0                 │ openHAB Core :: Bundles :: Mod
201 │ Active    │  80 │ 3.2.0                 │ openHAB Core :: Bundles :: Mod
202 │ Active    │  80 │ 3.2.0                 │ openHAB Core :: Bundles :: Mod
203 │ Active    │  80 │ 3.2.0                 │ openHAB Core :: Bundles :: Mod
204 │ Active    │  80 │ 3.2.0                 │ openHAB Core :: Bundles :: Mod
205 │ Active    │  80 │ 3.2.0                 │ openHAB Core :: Bundles :: Mod
206 │ Active    │  80 │ 3.2.0                 │ openHAB Core :: Bundles :: Mod
207 │ Active    │  80 │ 3.2.0                 │ openHAB Core :: Bundles :: Mod
208 │ Active    │  80 │ 3.2.0                 │ openHAB Core :: Bundles :: Mod
209 │ Active    │  80 │ 3.2.0                 │ openHAB Core :: Bundles :: Per
210 │ Active    │  80 │ 3.2.0                 │ openHAB Core :: Bundles :: Sem
211 │ Active    │  80 │ 3.2.0                 │ openHAB Core :: Bundles :: JSO
212 │ Active    │  80 │ 3.2.0                 │ openHAB Core :: Bundles :: Thi
213 │ Active    │  75 │ 3.2.0                 │ openHAB Core :: Bundles :: Thi
214 │ Active    │  80 │ 3.2.0                 │ openHAB Core :: Bundles :: Tra
215 │ Active    │  80 │ 3.2.0                 │ openHAB Core :: Bundles :: UI
216 │ Active    │  80 │ 3.2.0                 │ openHAB Core :: Bundles :: UI
217 │ Active    │  80 │ 3.2.0                 │ openHAB Core :: Bundles :: Voi
218 │ Active    │  80 │ 3.2.0                 │ openHAB UI :: Bundles :: Main
225 │ Active    │  80 │ 1.0.0.201802012106    │ org.osgi:org.osgi.service.jaxrs
226 │ Active    │  80 │ 1.5.0                 │ ThreeTen-Extra
227 │ Active    │  80 │ 1.27.0                │ SnakeYAML
228 │ Active    │  80 │ 2.1                   │ SI Units
229 │ Active    │  80 │ 2.1.0                 │ SI Quantities
230 │ Active    │  80 │ 4.2.1                 │ Stax2 API
231 │ Active    │  80 │ 2.1.2                 │ Units of Measurement Reference
232 │ Active    │  80 │ 2.1.0                 │ Units of Measurement Common Li
233 │ Active    │  80 │ 1.4.18                │ XStream Core
243 │ Active    │  80 │ 2.6.0                 │ JUPnP Library
244 │ Active    │  80 │ 3.2.0                 │ openHAB Add-ons :: Bundles ::
245 │ Active    │  80 │ 3.2.0                 │ openHAB Core :: Bundles :: Con
246 │ Active    │  80 │ 3.2.0                 │ openHAB Core :: Bundles :: UPn
247 │ Active    │  80 │ 3.2.0                 │ openHAB Add-ons :: Bundles ::
248 │ Active    │  80 │ 3.2.0                 │ openHAB UI :: Bundles :: Basic
249 │ Active    │  80 │ 3.2.0                 │ openHAB UI :: Bundles :: HABPa
250 │ Active    │  80 │ 3.2.0                 │ openHAB UI :: Bundles :: Icon
251 │ Installed │  80 │ 3.3.0.202112281002    │ openHAB Add-ons :: Bundles ::
openhab> bundle:restart 251
Error executing command: Error restarting bundles:
        Unable to start bundle 251: Could not resolve module: org.openhab.binding.vallox [251]
  Unresolved requirement: Import-Package: org.openhab.core.io.transport.serial

Result from Log:

2022-01-08 17:10:33.535 [WARN ] [org.apache.felix.fileinstall        ] - Error while starting bundle: file:/usr/share/openhab/addons/org.openhab.binding.vallox-3.3.0-SNAPSHOT.jar

org.osgi.framework.BundleException: Could not resolve module: org.openhab.binding.vallox [251]

  Unresolved requirement: Import-Package: org.openhab.core.io.transport.serial

	at org.eclipse.osgi.container.Module.start(Module.java:463) ~[org.eclipse.osgi-3.16.300.jar:?]

	at org.eclipse.osgi.internal.framework.EquinoxBundle.start(EquinoxBundle.java:445) ~[org.eclipse.osgi-3.16.300.jar:?]

	at org.apache.felix.fileinstall.internal.DirectoryWatcher.startBundle(DirectoryWatcher.java:1260) [bundleFile:3.7.2]

	at org.apache.felix.fileinstall.internal.DirectoryWatcher.startBundles(DirectoryWatcher.java:1233) [bundleFile:3.7.2]

	at org.apache.felix.fileinstall.internal.DirectoryWatcher.doProcess(DirectoryWatcher.java:520) [bundleFile:3.7.2]

	at org.apache.felix.fileinstall.internal.DirectoryWatcher.process(DirectoryWatcher.java:365) [bundleFile:3.7.2]

	at org.apache.felix.fileinstall.internal.DirectoryWatcher.run(DirectoryWatcher.java:316) [bundleFile:3.7.2]

2022-01-08 17:11:07.543 [WARN ] [core.karaf.internal.FeatureInstaller] - The binding add-on 'vallox' does not exist - ignoring it.

Thanks for helping me out.
What exactly have you done between you first try and the second try (after Edit#1)?

Here’s the first and almost certainly the only problem. Manually installed bindings cannot resolve and install requirements automatically and you don’t have any other binding that needs and/or installs it. You can fix this through karaf console:

feature:install openhab-transport-serial

Looks like this is because karaf’s line lenght limitation. Compare the lenght to other rows.

That was the missing part. I installed the openhab-transport-serial feature and it works perfect.
I´m realy happy thanks a lot gitMiguel

1 Like