Vdr binding

Is there any chance to get the vdr binding working at OH2?
Of course it would be nice to have a native 2.0-binding, but also 1.0 would be welcome :slight_smile:

Did you test it? Is it not working? If not, do you have an issue reference?

No, I didn’t test it yet :wink: am I the only one who uses this?

At least you seem to be the first one interested in running it on OH2 - someone has to be the first :slight_smile:
So please be so kind and do the testing an provide feedback - you can find details on how to do this here.

I know it’s an old thread, but I’d also be interested in using vdr binding with openHAB2. I installed openHAB on my PI using apt-get, but I cannot manage to even see the vdr binding. Neither the UI nor apt-get have a way of installing it. And the link you provided seem to no longer work. Am I missing something?

This binding isn’t marked as compatible, yet, so you will have to install it manually:

  1. Get the Binding (either download the complete OH1 addons package release https://bintray.com/openhab/mvn/openhab1-addons/1.9.0 or download just the .jar from last successful build https://openhab.ci.cloudbees.com/view/All/job/openHAB1-Addons/lastSuccessfulBuild/artifact/bundles/binding/org.openhab.binding.vdr/target/org.openhab.binding.vdr-1.10.0-SNAPSHOT.jar)
  2. follow steps from migration tutorial: http://docs.openhab.org/tutorials/migration.html#installing-unofficially-supported-openhab-1x-add-ons

I’m interested too :slight_smile:

Have someone test it in OH2? Will it work?

Yes, works for me. But to be honest, I’m on OH1.8 with my productive System, I use OH2 (unstable) only to evaluate yet. So yes, it works flawless here, but I don’t use it very often.

I would like to test the VDR binding for compatibility in OH2.

Using Udo’s link I found a newer .jar in https://openhab.ci.cloudbees.com/view/All/job/openHAB1-Addons/lastSuccessfulBuild/artifact/bundles/binding/org.openhab.binding.vdr/target/ and placed a copy in /usr/share/openhab2/addons (my installation on RPi3 was using apt-get … to extend the existing raspbian stretch setup). Unfortunately, I can’t get the binding to work following the migration tutorial. I’m stuck…

PS: After a service restart the log file shows

2018-06-17 16:12:24.457 [INFO ] [b.core.service.AbstractActiveService] - VDR Monitor Service has been started

Last time I tried this out with the recent nightly version (about 2 weeks ago) the vdr binding did not work anymore. I will have to retry this, 'cause this is the last show stopper for an upgrade.

Nevertheless, a true vdr2 binding is more than eligible.

The binding I installed in June is working fine (at least for me – on version 2.4.0.M5 :-).

The binding’s README.md was confusing to me in the section of basic configuration, but I finally found out how to do it. To make the README better I opened a PR https://github.com/openhab/openhab1-addons/pull/5701.

Where do I find the VDR binding? in Paper UI I cant find it.

The VDR binding is an openHAB v1 binding. By default v1 bindings are hidden unless you select the option to show them as well (in PaperUI go to Configuration->System and then in the “Add-on Management” section enable the “Include Legacy 1.x Bindings” option).

https://openhab.jfrog.io/openhab/libs-pullrequest-local/org/openhab/binding/org.openhab.binding.vdr/1.14.0-SNAPSHOT/org.openhab.binding.vdr-1.14.0-SNAPSHOT.jar

Thanks for the fast response. I have

services/addons.cfg

bindings=...,vdr

services/vdr.cfg

vdr:LivingRoom.host=192.168.30.34
vdr:LivingRoom.port=6419

items:vdr.items

Group gVDR
Switch VDR_LivingroomPower          "VDR (livingroom) Power"          (gVDR) {vdr="LivingRoom:powerOff"}
String VDR_LivingroomOSDMessage     "VDR (livingroom) OSD message"           {vdr="LivingRoom:message"}
Switch VDR_LivingroomChannelUpDown  "VDR Livingroom Channel Up/Down"  (gVDR) {vdr="LivingRoom:channel"}
Number VDR_LivingroomChannel        "VDR Livingroom Channel"          (gVDR) {vdr="LivingRoom:channel"}
Switch VDR_LivingroomVolumeUpDown   "VDR Livingroom Volume Up/Down"   (gVDR) {vdr="LivingRoom:volume"}
Number VDR_LivingroomVolume         "VDR Livingroom Volume"           (gVDR) {vdr="LivingRoom:volume"}
Switch VDR_LivingroomRecording      "VDR (livingroom) Recording"      (gVDR) {vdr="LivingRoom:recording"}

in the logs I see

2019-07-08 21:15:41.986 [INFO ] [b.core.service.AbstractActiveService] - VDR Monitor Service has been started
2019-07-08 21:30:13.988 [INFO ] [el.core.internal.ModelRepositoryImpl] - Loading model 'vdr.items'
2019-07-08 21:31:42.098 [vent.ItemStateChangedEvent] - VDR_LivingroomRecording changed from NULL to OFF

in karaf I see

openhab> smarthome:items list VDR*
VDR_LivingroomRecording (Type=SwitchItem, State=OFF, Label=VDR (livingroom) Recording, Category=null, Groups=[gVDR])
VDR_LivingroomChannelUpDown (Type=SwitchItem, State=NULL, Label=VDR Livingroom Channel Up/Down, Category=null, Groups=[gVDR])
VDR_LivingroomChannel (Type=NumberItem, State=NULL, Label=VDR Livingroom Channel, Category=null, Groups=[gVDR])
VDR_LivingroomOSDMessage (Type=StringItem, State=NULL, Label=VDR (livingroom) OSD message, Category=null)
VDR_LivingroomVolumeUpDown (Type=SwitchItem, State=NULL, Label=VDR Livingroom Volume Up/Down, Category=null, Groups=[gVDR])
VDR_LivingroomVolume (Type=NumberItem, State=NULL, Label=VDR Livingroom Volume, Category=null, Groups=[gVDR])
VDR_LivingroomPower (Type=SwitchItem, State=NULL, Label=VDR (livingroom) Power, Category=null, Groups=[gVDR])

What am I missing? When are the other items being set?

I just know where to find the binding. I don’t know if it still works ok.

I would expect that the items will change state when they receive an updated state from VDR, e.g. when you control the volume or select a different channel that you will then see the new state for the specific item.

Thanks. Will check. Sending Off to Power is not having effect yet. Will look into debugging later the week.

I’m interested in using the vdr-binding. Today I tested org.openhab.binding.vdr-1.14.0-SNAPSHOT & openhab2.5.0.M3 with the above settings. Unfortunately it does not work.

In Karaf it shows the Binding as active:
“258 │ Active │ 80 │ 1.14.0.201910112109 │ org.openhab.binding.vdr”

Logfile shows:
"[ERROR] [core.karaf.internal.FeatureInstaller] - Failed installing ‘openhab-binding-vdr’’’

Is there a chance to get a working vdr1 or vdr2 Binding? who is the developer of the Binding and
is he/she still active?

Did you install the OH1 Compatibility Layer yet? (Maybe by installing another OH1 Binding which already works as intended)

EDIT: just tried to install and seems to work:

2019-10-16 13:51:27.236 [INFO ] [b.core.service.AbstractActiveService] - VDR Monitor Service has been started

EEDIT2: Yep, working:

2019-10-16 14:07:29.450 [vent.ItemStateChangedEvent] - VDR_FF_Parents_Rec changed from NULL to OFF
2019-10-16 14:07:29.453 [vent.ItemStateChangedEvent] - VDR_GF_Living_Rec changed from NULL to OFF
2019-10-16 14:07:29.936 [vent.ItemStateChangedEvent] - VDR_FF_Server_Rec changed from NULL to ON

Other 1.x bindings work eg. Fritzbox tr064. Ok, if I just copy the file xxx.jar into the openhab\addons folder and do not set in addons.cfg bindings = …, vdr (otherwise the error will appear: Failed installing ‘openhab-binding-vdr’) then i
get in logfile:
“[b.core.service.AbstractActiveService] - VDR Monitor Service has been started”

and in event.log e.g.
…CommandEvent] - Item ‘vdr_wz_VolumeUpDown’ received command ON
…CommandEvent] - Item ‘vdr_wz_VolumeUpDown’ received command OFF
…ItemStateChangedEvent] - vdr_wz_VolumeUpDown changed from OFF to ON
…ItemStateChangedEvent] - vdr_wz_VolumeUpDown changed from ON to OFF

The VDR then reacts in principle to the PowerOff switch and switches off ‘Mute’ if you press the switch ‘VolumeUpDown’. It does not show any volume or channel number. In addition, I do not know how to turn the volume up or down with a switch in sitemap

It is also unclear why the binding can even access the VDR although nowhere (eg. vdr.cfg) a user and password are stored

The function of the binding is unclear to me and I think it should be revised