Very strange behavior / rollershutter closes on it's own without any rule

  • Platform information:

    • Hardware: RaspberryPi 3 B+
    • OS: Linux openHABianPi 4.14.34-v7+
    • Java Runtime Environment: openjdk version “1.8.0_152”
      OpenJDK Runtime Environment (Zulu Embedded 8.25.0.76-linux-aarch32hf) (build 1.8.0_152-b76)
      OpenJDK Client VM (Zulu Embedded 8.25.0.76-linux-aarch32hf) (build 25.152-b76, mixed mode, Evaluation)
  • openHAB version: 177 │ Active │ 90 │ 2.3.0 │ openHAB Core

  • ZWAVE version: 216 │ Active │ 80 │ 2.3.0 │ ZWave Binding

  • ZWAVE Device: ZWAVE Serial USB Stick

  • Issue of the topic:
    I have a really strange behavior. Sometimes at night a random rollershutter receives command “UP”, but I have no rule for this! It is a little bit scary. In the Log if have seen this:

2018-06-03 23:58:39.854 [vent.ItemStateChangedEvent] - rollershutter_eg_wz_right changed from 100 to 1

How is this possible? Is there some person outside with a Z-Wave sniffer?
How can the sender or trigger of those events can be logged for debugging?
Is there a way to restrict allowed sender of commands?

Many thanks for help!
Robert

I had the same. Do you have other zwave devices? Sometimes they trigger the rollershutter. Alarm sensors, smoke sensors, …

Check the thing config in habmin of the other things/devcies if they send messages to the rollershutters. or broadcast it.

First, enable permanent zwave and rules logging at debug level to verify that the ‘UP’ really isn’t initiated by openHAB.
Second, check all of your device associations. Some (sensors and remotes/2ndary controllers and keyfobs) can be explicitly associated with actuators such as your shutters so they work without the controller/OH server’s involvement.
Third, there might be ALARM zwave messages by any of your sensors that your rollershutters might be reacting to. As they’re broadcasted, you would spot these in the server logs if you have zwave debugging on.
Most actuators can be configured what to do on ALARM reception, and for roller shutters the default setting usually is to go UP.

I once had all of my house start opening (and some shut) shutters AND most of the ceiling lights started blinking. Man, THAT was scary.
Turned out it was caused by a combination of said default settings in the devices and a Fibaro multi sensor to send ALARM. Those motion sensors also have an acceleration sensor to detect tampering/removal. Or earthquakes, for what it’s worth … we had some massive garden works going on, and that apparently triggered the tamper sensor.

Many thanks for your quick responses!

Wow that’s sound crazy! :slight_smile:

Yes I have many of other sensors, actors and yes I forgot to configure the ALARM behavior.
After configuring all devices to not respond to alarm messages I will give it some time.
Maybe this was the issue and the behavior is gone. If not I set Debug level in logs to get more informations.

Many thanks!
Robert

Do enable debug logging nonetheless, it’s just an assumption for now and you need the log information to verify. OH needs to be in debug mode right when things are happening.

I enabled TRACE Mode and got an event tonight. Here are the logs.

I don’t know why the rollershutter (Node 12) is going up at 00:37.
Any hints on this?

Many thanks!
Robert

logs.pdf (221.9 KB)

No. It shows an incoming(!) command from that node 12 to drive to 100 (99) percent, with nothing to happen ahead.
The trigger seems to be the 99-command coming from the device. Might be some housekeeping builtin routine as the state of the shutter already is 100% (99 in zwave) and it essentially just repeats that.
Either way, while I don’t know why it’s sending that, it’s sending 99, so it shouldn’t go UP but stay DOWN.

Does it really go up or do you just believe that because of the log entry?
Did you reverse the up/down cables ? Have you also properly inverted the %age setting in the OH thing ?

I’d also double-check that device’s config, maybe you have an association to yourself.
Check HW (possibly bad cabling or water inside switch ?).
Reverse the UP/DOWN cables. While that does not explain the command, it should fix the shutters going up.
Recalibrate that shutter, eventually reset it.