Visual Studio Code Files cannot be saved *UPDATE Permissions problem

Hello,

I reinstalled openhab -> followed the official guide.
Everything works fine.

I also can access the Shared folders with the Explorer.
So the user for Samba and the control works.

After I installed Visual I added the Openhab addon and type my IP into the Settings.json.
Now I added the Folder from my Raspberry -> \192.168.178.50 and choose the Openhab-conf
I get listed all folders and files but I cant save or change the files

“Failed to save” Command failed: “C:\Users\Christian\Desktop\VSCode-win32-x64-1.41.1\bin\code.cmd” --file-write “C:\Users\CHRIST~1\AppData\Local\Temp\code-elevated-zluewx” “\192.168.178.50\openHAB-conf\html\index.html” Using --file-write with invalid arguments."

Did someone get an Idea what am I doing wrong?

Try openHAB-cli fix-permissions I believe is the command. You have a permissions problem most likely.

1 Like

oh… yes… it was a permission problem with my user which i created for Samba… AND a failure with the Visual Studio Configuration. I need to configure the raspberry folder into my network with a drive letter… not only the path… i dont know, that visual studio needs this…

thanks

1 Like

Awesome! Glad it’s fixed!!

I don’t know how, but I killed my permissions…

I tried to install the weather binding and find the article ->
https://community.openhab.org/t/openhab2-failed-installing-rrd4j-permission-denied/21712

i used to try this command -> sudo chown -hR openhab:openhab /etc/openhab2
after that, it was able to install the weather binding for me.

But now I don’t get access anymore to my Samba or Visual Code… //192.168.178.XX openHAB-conf folder

its a permissions problem again I think cause i get the same error (failed to save insufficient permissions), I googled a lot but don’t find a solution for me.
Can someone explain to me all the commands I need to use for my permission problem

@Kahzia are you running the openhabian? There is a fix permission option in the menu.

This usually fixes issues. Samba not working could be due to samba using a different user than what you set. You may need to set group or other may need to be opened.

mh my user is normally openhabian yes.

but i followed the offical instrudaction. And i created a user called “Samba” for Samba… and a few weeks ago i think i change the permission and everything works fine since yesterday.
I was not able to install the weather binding… permission error… so i googled it and find that command

sudo chown -hR openhab:openhab /etc/openhab2

after that, i was able to install my binding. But i changed the owner of the openhab2 correct ?
Now i need to know, how i change the permission for my user “Samba” or the group.

I think i tried it with openhabian too and it doesnt work anymore.

I am not finding it now on phone. I believe openhabian menu lives in /opt.

If you are having file system problems and you did not make major changes are you sure you as card did not get corrupt?

Void of a full reinstall, I would look to the openhabian docs and do manual install. Pull down the menu from github and get it running. Then use it, to try the fix permissions option. If openHAB still does not work properly, you can reinstall it with openhabian menu or apt.

Somewhere in the troubleshooting backup config manually or with openhabian. Just in case you need or decide to go the full start over option. Plus backups are always good!

mh okay I run the fix permissions and now everything works again… I don’t know whats going on there.
Anyways it works again :smiley: it will be never touched again