Voice commands to alexa don't operate dummy switches


(Scot) #1

Hello!

I’m new here and happy to be here!

I recently set up openhab on RPI and its working fine. Also, I have MQTT and remote access setup, and they’re working as well.

For reference, I followed this tutorial: https://www.mksmarthouse.com/setup-instalation

I have the openhab app on my phone, and I can connect locally and remotely to operate the demo switches I have configured. I also have an Amazon Echo Dot with the Openhab skill installed and connected to the myopenhab account.

Questions:

Openhab skill in Alexa does not see any of the demo switches that the openhab app (and the web interface on my PC) sees. It doesn’t see any devices, groups or scenes. (of note: I have no actual devices to control yet, just dummy placeholders in openhab)

I cannot control any of the demo switches by voice. I can’t even tell if Alexa can see the openhab setup. I went through the account linking process in the Alexa app and it said it was setup, but since I cant see any of the demo switches I’m thinking it’s not working. Every time I ask Alexa to turn on the kitchen, she says she can’t find a device or group name kitchen in my account.

Thank you for a wonderful system, I hope to get this working soon!


(SiHui) #2

You need to tag your items according to the homekit addon, see first post:


(Scot) #3

Ok thanks!

So I guess I have to go through the whole amazon developer account and AWS and all that?

If so, Im stuck here:

AWS Lambda Function
You can certainly create the lambda function manually, but the openhab team provides a script that does the heavy lifting for you.
If you haven’t already, clone the repo, and copy the template config files
git clone https://github.com/openhab/openhab-alexa.git
cd openhab-alexa
cp config_sample.js config.js
cp env_sample .env

Where do I do this? On the openhab pi terminal?

Im following instructions here: https://heathpaddock.com/2017/02/02/making-amazon-echo-alexa-sing-to-openhab2/

Im pretty techy but Im pretty confuzzled at this point :slight_smile:

Thanks for your help!


(Dan Cunningham) #4

No, thats only if you wish to run your own development version or your own myopenhab instance, not our hosted version. If you have linked your account successfully, and you have your openhab instance connected to myopenhab then you are almost there. The last thing that you need to do is “tag” the items you want alexa to see. The reason we do this is many people of lots (dozens, hundreds, more ? ) of items and you don’t want alexa to see all of them. So you need to add the right tag to your item file. See the first post in the link that @sihui mentions.


(Scot) #5

Ok, awesome, thanks so much for your help.


(Scot) #6

OK, I guess Im just not grasping something here.

Here is my items file:

//This is the Items File
//Demo Items
//Light Switches
Switch BedLightSwitch "Bedroom Light" <light>

The things file is empty because I dont actually have any “things” to control yet.

Here is the sitemap file:

sitemap home label="MK-SmartHouse"
{
       Frame label="Demo"
       {
               Switch item=BedLightSwitch
       }
}

I guess Im just not understanding how to “tag” items, I thought thats what the items file does, give names to things.

Ive googled until im blue and Im just not finding any information on item tagging. I have enabled the HomeKit on Alexa but still cant find where to link to voice commands.

I have no other hardware other than Amazon Echo Dot and RasPi running openhab 2.0.

Is a physical device required to make this work? I have a couple wifi enabled power strips on the way but just wanted to get some dummy switches responding to voice commands through alexa first.

I have read through

and

http://docs.openhab.org/addons/io/homekit/readme.html

But something still isnt sinking in…


(Hans-Jörg Merk) #7

Properly tagged would look like

Switch BedLightSwitch "Bedroom Light" <light> [ "Lighting" ]

(Scot) #8

VICTORY!

Thank you SOOOO much!

Can someone give this guy a cookie?!?!?