VS Code openHAB "Unable to open"

When I select a file with an error it should open the file directly in the editor. However I get this error:

I added the openhab folder via a mapped drive. I can save and create new files so it is not a permission problem. However when I click the “create file” button in the error window it will create a file on my C:\ drive (C:\openhab\conf…)

Can someone help me or is this feature currently not working?


I do not use Windows but do remember reading that some have needed to create a different drive e.g. Z drive and use that for OH.

Will post back if I can find the topic.

thx I’ve already tried that but maybe you just need to map the drive directly to the conf folder or to the openhab folder, one folder above conf?

Duplicate from

This is a known error in LSP which hasn’t been solved so far.

yeah thats exactly the same problem maybe we can close this thread and continue on the other one?

This topic was automatically closed 41 days after the last reply. New replies are no longer allowed.