WakeOnLan / Networkbinding - no wake up after 30min

Good evening everybody,

I have one problem and i’m stuck with it. I want to ask here first in front of opening a bug report.

I have a Ubuntu server which is not necessary to run 24/7. With my Openhab3 i would like to start it, which is working under some circumstances as followed.
A Openhab 3 Instance (3.3.0) running at a windows server VM on Ubuntu 18.04, installed via openhabian, which is running fine and without any problems so far.
When i shut it down and send the “magic Packet” via Openhab within a few Minutes after the shutdown, the WOL works perfectly fine and the server start booting.
If i wait for example for more then 30 minutes and send the WOL packet from openhab, the server does not wake up any more.
If i send the WOL package from my pfSense firewall or straight from the router 30minutess later or more, the server respond straight ahead and start booting. I don’t have any error messages inside the logs.

2022-08-01 22:16:37.822 [INFO ] [twork.internal.WakeOnLanPacketSender] - Wake-on-LAN packets sent (IP address: / 2022-08-01 22:16:37.824 [INFO ] [twork.internal.WakeOnLanPacketSender] - Wake-on-LAN packets sent (MAC address: 70:85:C2:4B:80:CD)

I’ve implemmented the IP and MAC magic packet option inside the same rule to try both at the same time, but nothing changed. I’ve already tryed to send the magic packets multiple times with a delay in between, but no success. I’ve configured the server as a networkdevice, and selected port 9 inside the networkdevice binding settings to make sure the packet will send on the right port.
Do you have any idea or recommended settings for the binding i could try?
I would appreciate you help and/or feedback on that.

Best regards

Don’t set the IP but the broadcast IP (i.e. as the server may have no valid IP address any more.

Hello Udo,
thanks a lot for you’re reply.
I’ve found already a similar page on the internet, that mentiond the broadcast IP instead of the target IP. I’ve tryed it in different configurations and already enabled a Any Any Rule on the Firewall to make shure the message are not blocked or rejected.
I thing i should try to capture the TCP/UDP packets and check where the different’s are between the firewall command / packets and the openhab command.
Based on the fact i don’t have any experience with recording / monitoring TCP/UDP packets, that is gonna take some time.
But thank you for your help and support.