Warning org.openhab.binding.mqtt.homeassistant.internal.discovery.HomeAssistantDiscovery.publishResults

Hello all,

during the openhab startup I get always this error

java.lang.NullPointerException: null
	at org.openhab.binding.mqtt.generic.MqttChannelTypeProvider.derive(MqttChannelTypeProvider.java:132) ~[?:?]
	at org.openhab.binding.mqtt.homeassistant.internal.discovery.HomeAssistantDiscovery.publishResults(HomeAssistantDiscovery.java:248) ~[?:?]
	at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:515) ~[?:?]
	at java.util.concurrent.FutureTask.run(FutureTask.java:264) ~[?:?]
	at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(ScheduledThreadPoolExecutor.java:304) ~[?:?]
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1128) [?:?]
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:628) [?:?]
	at java.lang.Thread.run(Thread.java:829) [?:?]

But I don’t have any Homeassistant in my environment what should I do?

Firstly, this is a warning so it’s not something that is causing problems. It’s safe to ignore.

The error is coming from some problem during scanning for Home Assistant MQTT topics. Since you don’t have any devices publishing using the HA MQTT standard, this further confirms that this warning can be ignored.

There was a PR some time ago to correct this (or something like this). What version of OH are you running?

OH3.4.1 an read about this


Should I file another PR?

Based on that thread, have you turned off discover? There’s a toggle at the very bottom of the Broker Thing (check “Show advanced”).

Yes, its true

But even than it should be no null pointer exception