Weak up z-wave sensor periodically dont' work

Tags: #<Tag:0x00007f433ca4a958>

Hello, as a lot I use zwave for certain sensors, I tried with the help of many posts on the forum to know if a sensor is disconnected, I placed in a database influx the records at each update , and configured the dongle to wake up the sensors periodically, and this on 3 different dongles, nothing to do with the dongle never wakes anyone up and suddenly I am unable to be warned if a sensor is lost, I use the binding "expire ", do you have any experience and solution for this very annoying problem? thank you in advance

Ps: with zigbee2mqtt for example it works very well 'I also used other box and again even in zwave I have alarm settings which are well done, but on OH, 2.5 and 3.0 … None I do not understand

Thanks for any help on this

No dongle ever wakes up any zwave sensor. If it is asleep, it has to wake by itself. Usually that is configurable in the sensor.

‘Expire’ is exactly the right thing to detect missing updates.

The sensor needs to wakeup on its own as the dongle can’t wake up a sensor which isn’t listening due to its sleep.
As Roosko57 wote: decrease the wakeup period of the sensor, but be aware it will affect (=shorten) the lifetime of battery operated devices and you need to change batteries more often for these devices.

OK so I need to look closely on sensor… Thanks for your help

1 Like

Purely out of curiosity, what kind of sensor is it? (brand and model)

1 Like

fibaro and aeotec

hello, I try to understand what is preventing updating the status of my door sensor.
I have adjusted the following wake-up parameters on the sensor

then I could see that the sensor woke up 9 minutes ago

for my item I have the following setup:

Contact   ZWaveNode009ZW112DoorWindowSensor6SensorDoor        "Porte Local Tech[%s]"           {channel="zwave:device:e0f86061:node9:sensor_door", expire="10h"}

So my item if it has not received an update will go to “UNDEF”.
unfortunately the status always remains on “UNDEF” the weake up does not change anything.
Is there something that I’m doing wrong?
Thank you for your precious help, this sensor management is very important to be sure that it works.
Thank you

You have set the Polling Period to 6hrs.
So device will wake up every 6hrs and ask the controller if there is any change in settings - it will NOT post its status.
After that it will sleep again 6hrs.

As this is a contact sensor it will wake up immediately when the status (ON / OFF or OPEN / CLOSE) changes and send the new status to the controller.
If the device has a bad connection to the controller this message could get lost.

This device has just one neighbour node 8.
If this is also a battery device and there is no other listening device online the message is also lost.

this is a test network , there are 2 devices , one door sensor and one wallplug , so what is the best way to know if a sensor is deconnected or works badly ? there is a way ? or i just need to set a rule test if sensor value is “null” or “UNDEF” to be warned ?

thanks for your precious help

You have a lot od nodes on the network if there are only 2 devices. You likely have zombie nodes defined on the controller affecting network routing. I usually use the Windows based PC Controller software to remove them from the stick.

Devices sometimes try to route through the non-existent nodes to reach the controller.

in fact yes there are gost nodes , i clean then know thanks , for what i see i need to learn mode about zwake managing…, so the controller can see if a sensor is lost ? and can tel me if is the case ?

You can’t, directly. OpenHAB cannot tell if a battery device is sleeping normally, or has been stolen or crushed with a hammer.

What you can do is configure the device to make periodic reports e.g. battery status. Then you can detect missing reports.
The Item ‘expire’ feature is purpose made for this.

1 Like

yes i know i try to use the expire feature, but if the sensor don’t actualise state (if there are no change apparently sensor send update only if new state) the expire set for exemple “UNDEF” after 10h , and the status stay unchanged until i open the door,
so if i open this door only one time per week how i can know there is a problem with this sensor ? i hope i explain right myself , thanks a lot again for your help

To repeat

You do the “detection” on some other channel that is not random.

the problem is i don’t see on this particular sensor battery report setup, so thanks again for your help

Then you’ll only be able to detect a missing sensor after 10 days.

It’s a rubbish sensor if you can’t configure it to periodically report battery. I think you just have to find out how, really.

The “command poll period” you showed in an earlier post has nothing to do with wakeup at all. It tells the binding when to poll a device after it has been sent a command. You don’t send commands to sensors, it does nothing here.

Don’t forget if you do change device settings at openHAB end, they cannot be loaded to the device until it wakes up. No instant cures.

here is some info’s:
for these server i’m on “2.5.11-1”
The controler is a “Z-wave.me v2”
The door sensor is a “ZW112 Door/Window Sensor 6” from Aeotec

Here is the param’s i can change in the door sensor :slight_smile:

actually i set a warning if battery don’t change since 4 week

like this

rule "Detection d'anomalie  Batterie  si pas de changement depuis 4 semaines"
when
cron  	"0 00 19 1/1 * ? *"//demarre a 19h  tout les jours 
then
val BatteryDevices = It_Group_Battery.members.filter[sensor|sensor.updatedSince(now.minusWeeks(4), "influxdb") == false] 

    BatteryDevices.forEach [ sensor |
        msg5 = msg5 + (transform("MAP", "BatteryAnomalie.map", sensor.name) + ': ' +  '\n')
        logInfo("Sensor Statut ","possible anomalie sur " + sensor.name + ": " + sensor.changedSince(now.minusWeeks(4), "influxdb").toString )        
        ]
   
     if (msg5 != "" )
{
  //Do message ..Email..blabla...
}
end

And for Contact state door sensor i set 2 Weeks .
Apparently I have no choice but to wait for the battery to drop? or a possible opening of the door, this seems to be a good solution?
for other temperaturte, energy monitor exc … I use “expire” which is very good work

Don’t forget if you do change device settings at openHAB end, they cannot be loaded to the device until it wakes up. No instant cures.

great info! It can avoid a lot of problems indeed!

On my 3.0 test server “Rpi4”

i have the same param’s (controler and sensor as not the same Aeotec usb dongle and fibaro doors sensor)

so the only commune parameters is “Wakeup Interval”

is simply that ? if so why is this sensor not updating …

thanks again for your time , I’m just trying to understand and solve this problem

Perhaps this will help

You need to MANUALLY wake up the device if the wakeup period has not previously been set. I’m not sure if this is the case or not, but you cannot just change the value in the UI and expect the device configuration to change. The device must wake up to allow the binding to transfer the configuration - if the device is waking up periodically already, then it will be transferred at some stage - if not, you must manually wake the device.

I see in this image it shows PENDING status - this means that the configuration has not transferred to the device yet. You can either just wait until the device wakes (hopefully!) or manually wake the device.