Weather Binding - Disabling Native Weather THING

I have a rule to disable THINGS when my Internet connection drops. The only THING I can not disable is the native weather binding because there is NO things - just items. Does anybody know the syntax to do this?

Syntax of other THINGS getting disabled:

				sendHttpPutRequest("", "application/json", 'false')									// Disable AirQuality Default
					Thread::sleep(2000)  // 2 second wait

Error Message I get when Internet drops:

2019-07-27 14:26:09.810 [ERROR] [nal.provider.AbstractWeatherProvider] - FORECASTIO[homeFIO]: Can't retrieve weather data: Error: response is empty!

My weather binding uses the weather.cfg file:


Can I disable the scheduler that polls the weather binding vs a THING as an option? Which is the best way to handle this?

Best, Jay

That is an OpenHAB 1 binding set up with a configuration file. I am not sure how to disable it except through Karaf commands. possibly.

There is no syntax to do this. It’s impossible to do for OH 1.x bindings. That is just one of the many reasons 2.x was created and capabilities one gets by using 2.x version bindings.

The only way to disable these items will be to edit the .items file to remove the Items.

You could perhaps uninstall the Weather binding itself which you should be able to do through the Karaf console or the REST API, but only if you are not using addons.cfg to install add-ons.

1 Like

If they were in a separate file, perhaps just renaming from .items to .disabled

Thanks guys! I’m going to move the ForecastIO from 1.x weather binding to the dedicated ForecastIO (DarkSky) binding which should resolve my disabling thing issues.

Best, Jay