Weather Webview not working (sometimes)


In general my weather webview works normally.
However sometimes I get the Error instead of the forecast:
HTTP Error 500
Weather locationId ‘home’ does not exist.

In my openhab.log I find:

2016-01-13 12:50:36.882 [WARN ] [e.jetty.servlet.ServletHandler] - /weather
javax.servlet.ServletException: Weather locationId 'home' does not exist
        at ~[na:na]

In most cases a powerdown for some time solves the issue.
I have read some posts here, but their problem obviously based on a wrong configuration without any ‘home’ item.
I this a know issue, that it’s sometimes working and sometimes not?

Does nobody else have this issue?
I have read some similar problems related to SD-cards not working properly.
So might this be the issue?
If the SD-card quality is the issue, what kind of Raspberry or similar can be recommended with sufficient integrated memory!?

I went back and checked everything (again).
I also checked the the troubleshoot section of the weather binding.

Sometimes after a complete shutdown and reboot the webview works perfectly.
In the log in debug mode I get:

LocationConfig[providerName=YAHOO,language=de,updateInterval=10,latitude=Xx.,longitude=Yy ,locationId=home,name=Zuhause]

and accordingly the weather item updates#.

Adding item Weather_Temp_Min_3 with ForecastBindingConfig[locationId=home,forecast=3,type=temperature,property=min,roundingMode=HALF_UP,scale=0]

So please, if anyone experiences the same problem, please let me know.

PS: As I am still developing, I restart my openhab frequently.
However, now, that the webview is running properly, I will leave it…

Which OpenHAB version do you use?

I actually upgraded to 1.8 and obviously it works much more reliable.

I did not pay attention a while because I had other problems :wink:
But it’s still not reliable.
Every now and then I still get the same message:
javax.servlet.ServletException: Weather locationId ‘home’ does not exist

Even on 1.8.3 it’s still there…
It’s weird that it works sometimes and sometimes not - without any changes.

It’s still there.
I restarted 1.8.3 a few times to make it work (no config changes in between) and webview ist working fine for now. Let’s see how long it takes until it’s messed up again.

I wonder why it’s obviously not working out of a sudden without touching the config!?

+1 I have the same issue since installing snapshot for my webcam