Webview Graphs not showing in Android App

Hi All,

Just updated openhab app on Android today, and noticed I cannot see my Graphana graphs using my local URL connection and was working prior to the update. The graphs display correctly in chrome on my phone and PC correctly.

Any thoughts?


Sitemap snippet:

Text label="Solar" icon="solarplant" {
                Webview url="" height=10
                Webview url="" height=10
                Webview url="" height=10

Android App version: 2.4.0 - 7 Nov 2018 6:27:53 am
Openhab version: 2.3.0

Same issue here… :frowning:

Same Problem. Downgrade to Android App version 2.2.0…:confused:

I don’t have a Grafana installation, but there is a public demo server. Is this an url you use for the graphs: https://play.grafana.org/d/000000012/grafana-play-home?panelId=4&fullscreen&orgId=1?
Edit: or this: https://play.grafana.org/d-solo/000000012/grafana-play-home?refresh=2h&orgId=1&panelId=5

Same for me too. No Grafana charts (webview) anymore after update to 2.4.0 and beta version 2.3.10 -beta has the same problem.

The charts still work from BasicUI for the same sitemap.

URIL is like this


How do I downgrade it to the old version?

I have reverted the commit that caused this issue and tagged a beta version. You will receive that soon via F-Droid and Google Play. If you can confirm the fix, I can publish a new stable version.


Updated to Beta 2.4.1 and after login was completed the Grafana webview charts work again

1 Like

I’ve tested the Beta and this is working again.

The external Grafana link works no problems, but my local Grafana graphs are showing a login page for each of my graphs. Pretty sure that’s a setup thing on my end that I need to look into.

Thank you all for your efforts.:+1::+1:

Working again with Version 2.4.1. Thanks for the effort!

For Downgrade uninstall the actual version, download the release from github (apk), be sure that the security setting in your Android device is ready for side load (Installation from unsecured sources), install the apk and switch the auto update in play store to off, don’t forget to switch off the unsecured side load. That is it. It could be possible that you must rewrite the settings in the app for oh-ip.

The new version for the beta app fixed it but thanks anyway. Useful to know.