Wemo Binding Failing to Discover Plugs

I have the Wemo Binding installed through paperUI and if I try to discover my plug Wemo Mini Plug it very quickly fails jumps to thing not found. If I try to add it manually it asks for a UUID which isnt refrenced anywhere in ANY wemo documentation or device summaries and the documentation for the Binding it self fails to explain where to find said UUID (This is obviously the wrong name and should be changed are you looking for the MAC or Serial Number?) A MAC address will make something show up as online but toggling it does not toggle the intended Wemo Mini Plug. I had this binding and plug working at my last house before the move!

If you had it running with the same device before the move, something is wrong in your network setup, as the binding has not changed for quite some time. Autodiscovery is definitely working.

Well I hadnt updated the plug in ages and I just updated its firmware before try to rebind in hopes that I would avoid the disconnect issues I use to have with the binding to be honest. I also made sure UPnP is enabled as well on my D-link DIR-819. The binding never seemed to be the most stable it probably needs updating unfortunately as the plug was always responsive from the wemo app now and before during disconnects. Do you happen to know how to find the UND PaperUI ask for. I just noticed the UI and Doc call it different things but neither exist according to wemo documentation.

If autodiscovery does not work, configuring the thing manually will not make it work either. The UUID is used to identify the device within UPnP. Seems that Belkin again broke something with the firmware update. If so, I cannot debug this issue, as the Mini Plug is not available in Germany.
To be honest, the binding is as stable as it could be, but Belkin‘s firmware is crap, they are more and more trying to force usage of their WeMo Cloud and restrict local control of the devices.

Oh no is there any way to downgrade the plug? I have another one I havent unboxed yet hopefully its on an old enough firmware but there go’s the smart plug for the arcade cabinet!

No, you cannot downgrade the firmware.

Ok I’ve now setup the second Wemo Mini and the app wants me to update it so it is definitely on an older version of the Firmware but unfortunately it doesn’t show either. Also based on the network statement I googled and found this UPnP Tester I run from windows and I pick up my Router, Philips Hue bridge, and Kodi so I don’t think its my network unless it could be something else, but the Wemo Mini’s don’t show up at all in its list of Network UPnP devices!

Belkin’s terrible firmware is why I almost completely abandoned Wemos in favour of TP-Link Kasas. It’s amazing that they’ve never been able to get it to a stable state (and I’ve had Wemos since they were first released).

If I recall correctly, Wemo MAC addresses are one digit off from what is written on the devices when you view them on the network (though I can’t remember if it’s one digit up or one digit down). However, that shouldn’t be a factor here, since OH would only care what’s written on the device…just what shows up on the network.

At your old house were you using the Wemo with the same router, or did that change? And are you using DHCP or have you assigned a static IP address?

At the old house I was using a Bell provided router here I picked up the DIR-819 for a private subnetwork. I am using DHCP but have assigned most Devices IP’s as reservations on the router except the plugs would I possibly have better results with static IP’s for them as well?

I prefer static IPs, but I don’t know if it’ll help.

Are your plugs and openHAB server on the same router? If they aren’t, OH might not find them.

Yes all the smart devices are mine and are connected to the same network. Keeping them private was the main reason I setup a subnetwork as they provided internet at my new apartment.

openHAB server and WeMo devices have to be on the same subnet, as UPnP is not working across subnets.
@Dracrius did you change your openHAB version or is it the same installation?

I’m on the same installation but I was considering finally updating as I’m at least a year out of date. And to be clear they are on the same subnet.

Feels like a router setting, since that’s the most significant change to your setup.

I suggest disconnecting your router from the Internet and then systematically turning off any protective features to see if any of them are interfering with autodiscovery.

Presumambly the settings under Firewall PPTP, IPSec, RTSP, SIP ? I honestly dont know what any of those are or there is Enable SPI which is on. I know a bit about networking but almost nothing about firewalls unfortunately I need to learn more security.

I’d suggest a forum search for your router model to see if anyone else had similar issues. If not, you’ll have to resort to Google to figure out what your router might be doing to prevent devices from talking to each other.

When you find a solution, I look forward to hearing it!

No solution yet as my google searches dont give up much of anything for UPnP issues with Wemo or my router but I have notice that from a UPnP app on my phone I can see the switches while the desktop (Ethernet) does not show the Wemo Plugs and the Server is also on Ethernet. I’m trying to research reasons for that and the basic wireless isolation mode doesnt seem to be a feature of this router.

Finally got them to show up I think it was disabling Windows firewall on the computer that is my Openhab server, Strange that I didnt before but that its blocking UPnP with this router.

Glad you got it working. I don’t know why that would have changed…maybe a Windows Update? Either way, good reference for the future.

Glad you found it and it is neither a Binding issue, nor a firmware update issue :+1: