WeMo Binding not working, nothing in log

Been trying to get the WeMo Insight and WeMo Switch (and the motion detection, although I can wait on that…) to work. The problem I’m running into is that I’m following the directions on the wiki, but when I start up the server, I don’t actually see any reference to WeMo or the devices in the log. I’ve tried entering in the names. I’ve tired it two ways.

Group Wemos

Switch WemoLight1	"Wemo Light 1" 	(Wemos) 	{wemo="WeMo Insight"}
Switch WemoLight2 	"Wemo Light 2" 	(Wemos) 	{wemo="WeMo.Insight.1X1"}

On my sitemap, I’ve added:

Group item=Wemos label="The Wemos"`

So I’ve tried the device ID and the actual device name as entered into the mobile device. I can control it from the iOS app with no issue.

I have the Hue lights working just fine so far, so it’s not just openHAB.

So basically, I dropped the addon org.openhab.binding.wemo-1.7.1.jar into the addons folder. I’ve restarted the server. I cannot figure this out.

1 Like

Is there no entry in the log saying that the WeMo Binding has started?
Please try the 1.8 snapshot to be found on cloudbees and give this another try.
There had been some discovery issues with the WeMo devices.
Please read the WIKI for new configuration of the items.


1 Like

As well try not to use blanks in the wemo naming.

I dont have any blanks or special haracter within the wemo switch naming.


1 Like

I’m in 1.7.1. Should we be using 1.8?

EDIT. Link appears to be dead.

I’ll give this a try. maybe that was the issue. i’ll report back. thanks!

okay, so I tried 1.8, completely fresh, and I’m still not seeing anything when I tail the log.

xxx:runtime xxx$ ./start.sh
Launching the openHAB runtime...
osgi> 2016-01-17 20:11:50.924 [INFO ] [.o.core.internal.CoreActivator] - openHAB runtime has been started (v1.8.0).
2016-01-17 20:11:51.433 [INFO ] [o.o.i.s.i.DiscoveryServiceImpl] - mDNS service has been started
2016-01-17 20:11:51.450 [INFO ] [o.o.i.s.i.DiscoveryServiceImpl] - Service Discovery initialization completed.
2016-01-17 20:11:52.511 [INFO ] [penhab.io.rest.RESTApplication] - Started REST API at /rest
2016-01-17 20:12:01.625 [INFO ] [.o.u.w.i.servlet.WebAppServlet] - Started Classic UI at /classicui/openhab.app
2016-01-17 20:12:04.826 [INFO ] [.service.AbstractActiveService] - Hue Refresh Service has been started

It just sits there. Finds the Hue, but not the WeMo. I changed the names to exclude spaces. Still not working… hmm…