Wemo Insight values not showing in UI

I have a problem with a Wemo insight switch which is correctly feeding values into openHAB, but I am unable to then see those values in the UI. I’m unsure if it’s an issue with the binding, or if I’m not setting it up right in the sitemap config, or what.

I’m using openHAB 1.8 and the 1.8 wemo binding. In my items file I have the following (amonst other things)
Group Oliver (All)
Group Oliver_Heater (Oliver)
Switch Heater “Heater” (Oliver_Heater) {wemo=“Insight-1_0-221512K120035B”}
Number Heater_Power “Current Power (W)” (Oliver_Heater) {wemo=“Insight-1_0-221512K120035B;currentPower”}

In my sitemap file I have this:
Group item=Oliver_Heater label=“Heater” icon=“heating”
Text item=Heater_Power

In the logs I see the value updating and persisting (I added a rule to log “when Item Heater_Power received update”
[p.rrd4j.internal.RRD4jService] - Stored ‘Heater_Power’ with state ‘61.98’ in rrd4j database
[org.openhab.model.script.rules] - Power updated: Heater_Power (Type=NumberItem, State=61.98)
I also see values in the habmin interface

In the UI I see no values apart from the on/off status, which works absolutely fine. I’ve tried using android UI and the standard web UI with the same results. I’ve also tried the onToday and onTotal values, with the same results there too. I’m rather stumped as to what to try next or how to investigate this further?

your item definition is not correct, please try
Number Heater_Power “Current Power [%2f] (W)” (Oliver_Heater) {wemo=“Insight-1_0-221512K120035B;currentPower”}

Ah many thanks, I see. I’ve added [%.0f] to the item descriptions and it’s now working. Thanks a million!