Wemo Switch problems

Hope someone can help, I am new tom openHab and working through the initial tutorial. I have succesfully configured openhab to recognise my phone when it attaches to my home network and can display its state on the Basic UI. I would now like to have the system turn on a Wemo Switch when it detects the presence of the phone. Problem is I can not get openHab to ‘discover’ the switch - neither can my Amazon echo as it happens, so I expect it is a characteristic of the switch. I have tried to create it manually but it appears I need some address related parameters that I don’t know how to find. The switch works as my iPhone can happily turn it off and on. I would appreciate it someone could give some advice on how to create this switch manuallyu.

It would be helpfull if you could post some details about your system (board, cpu, os, java version).
You wrote your Echo does not see the WeMo device, so this seems to be a not openHAB related issue.
What WeMo switch do you have and what firmware is it running.

Fair point.
I have OpenHab2 installed on a Raspberry Pi Version 3 with Raspian Jessie and Java 8.
Wemo Switch is at latest Firmware (upgraded yesterday) - still trying to find out how to determine the version and the switch is the wall plug only version, looks like an insight switch but without the function. Have checked the upnp router setting and all looks ok. I dont think this is an openHAB issue, but I do see that others have experienced similar behaviour so was hoping to get some pointers. If I cant solve the problem the Belkin Wemo will probably be cast aside.

A bit more info. Viewing the log while initiating a Thing search with the Wemo Binding results in the following log entry - repeated a number of times

2017-04-06 18:33:16.521 [ERROR] [.jupnp.transport.impl.DatagramIOImpl] - Exception sending datagram to: / java.io.IOException: Invalid argument

The compete message:

2017-04-06 18:33:16.011 [ERROR] [.jupnp.transport.impl.DatagramIOImpl] - Exception sending datagram to: / java.io.IOException: Invalid argument
java.io.IOException: Invalid argument
at java.net.PlainDatagramSocketImpl.send(Native Method)[:1.8.0_65]
at java.net.DatagramSocket.send(DatagramSocket.java:693)[:1.8.0_65]
at org.jupnp.transport.impl.DatagramIOImpl.send(DatagramIOImpl.java:155)[162:org.jupnp:2.2.0]
at org.jupnp.transport.impl.DatagramIOImpl.send(DatagramIOImpl.java:148)[162:org.jupnp:2.2.0]
at org.jupnp.transport.RouterImpl.send(RouterImpl.java:300)[162:org.jupnp:2.2.0]
at org.jupnp.protocol.async.SendingSearch.execute(SendingSearch.java:90)[162:org.jupnp:2.2.0]
at org.jupnp.protocol.SendingAsync.run(SendingAsync.java:52)[162:org.jupnp:2.2.0]
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)[:1.8.0_65]
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)[:1.8.0_65]
at java.lang.Thread.run(Thread.java:745)[:1.8.0_65]

Ok, the log says Java version 1.8.0_65, this is quite old. Please update to the latest and it should work.

Problem solved, thank you very much for the assistance.

For anyone else who has a similar problem, I followed the instructions here ==>

to upgrade the java version currently shipped with Raspbian Jessie