Which ZigBee stitch is the right one for my setup?

Tags: #<Tag:0x00007f5c90a88880> #<Tag:0x00007f5c90a88790>

I use the following devices which also work well with the Telegesis Coordinator:
3x Dresden Electronic FLS.CT W-WW Dimmer
2x Gledopto GL-C-007 & 008 RGBW Dimmer
1x ShenZhen Homa 1001 RGBW Dimmer
2x OSRAM Plug 01
3x OSRAM PAR15 50TW W-WW bulb
2x OSRAM CLA60 TW and CLA60 RGB bulbs
2x Philips LWB010 and LWV001 bulbs
3x Philips RWL021 Dimmer switch

I also have devices in use that work poorly mit der Bindung aber sie laufen wunderbar mit Zigbee2MQTT und dem “CC2531” als HomeAssistant MQTT Component:

2x Danalock V3 ZigBee, they do not report back and have to be paired every day
because they react unreliably to commands.
5x “Xiaomi Aqara Temperature, Humidity & Pressure Sensor”, which deliver the 3 main values, but no battery.

Then I still have devices that only run via Zigbee2MQTT, which are recognized in OH but there no items:
OSRAM Smart + Switch
IKEA Tradri Switch
Xiaomi Door / Window Sensor

I would like to operate all of these devices via Chris’ ingenious ZigBee binding. I suspect that partly the Telegesis stick is the problem, because I keep reading that people have Xiaomi things. So I ask is there anyone who uses components like me and with which stick, with which I then get it. Maybe it is enough if I flash the CC2531 for OH, but I don’t have a programming device at the moment. To make matters worse, I don’t get every stick here in Austria.

You tagged this thread Zigbee binding but mention Zigbee2MQTT which is a different binding. Which are you using??

As the text should say, both at the moment. The Telegesis only works with the ZigBee binding, sorry I should have mentioned. I use Zigbee2MQTT for devices that do not work with the binding, but I would like to get rid of that, hence the question of which stick with the binding could cover all my devices.

I will tag as Zigbee so @chris the developer will respond. I personally so not use Zigbee but make use of his excellent Z-Wave binding.

You have one stick for Zigbee and another for zigbee2mqtt? I di not know of any devices requiring zigbee2mqtt.

1 Like

Did you tried Deconz/Phoscon with a Conbee USB-Stick? Works great for me with 60+ devices. Works also with the xiaomi/aqara sensors. The Phoscon Software gives detailed informations about the zigbee mesh and is working on openhabian as well.

1 Like

Now z-wave is marked, was that me? I also use his Z Wave Binding, all my presence sensors run over it and that very reliably.

Thanks for the hint but I would prefer the ZigBee binding and not switch to a third system. With Zigbee2MQTT all devices work (except the Homa 1001) but I would prefer to have everything in OpenHab.

No, I did that, :smiley: Chris is in the UK but he should be along when he gets a chance.

Forgive my confusion, but why Z-wave, is it a ZigBee topic?

My mistake. Sorry.

Fixed

1 Like

CC2531 - I cannot recommend it with the ZigBee binding. After I had read in a few LED lamps from Philips and Osram and 2 RGBW, CT dimmers, nothing worked anymore. Restarting OpenHab and the read things were okay again. This repeats itself again and again after a few read-in attempts.

Philips RWL021 dimmers are recognized, but do not work the same (3x current FW).
Dresden Electronic FLS.CT W-WW dimmer - OK.
ShenZhen Homa 1001 RGBW dimmer - OK.
OSRAM connector 01 - OK.
Philips LWB010 and LWV001 lamps - OK.
OSRAM PAR15 50TW - OK.
OSRAM CLA60 TW and CLA60-RGB - OK.
Gledopto GL-C-007 & 008 RGBW-Dimmer - NOK, not channels.
Danalock V3 ZigBee - NOK, no channels.
Xiaomi Aqara temperature, humidity and pressure sensor - NOK, not found.
IKEA Tradfri switch - NOK, not found.

Now I have ordered the Bitronvideo ZigBee USB stick and is now my fourth stick (QIVICON never went online, Telegesis, CC2531).

I also flashed CC2531 for Zigbee2MQTT and installed and tested it with Home Assistant:
Philips RWL021 dimmers - OK.
Dresden Electronic FLS.CT W-WW dimmer - OK.
ShenZhen Homa 1001 RGBW dimmer - OK.
OSRAM connector 01 - OK.
Philips LWB010 and LWV001 lamps - OK.
OSRAM PAR15 50TW - OK.
OSRAM CLA60 TW and CLA60-RGB - OK.
Gledopto GL-C-007 & 008 RGBW-Dimmer - OK.
Danalock V3 ZigBee - OK but not stable.
Xiaomi Aqara temperature, humidity and pressure sensor - OK.
IKEA Tradfri switch - OK.

The devices were also created automatically in OH (home assistant = true).
The result would imply staying with Zigbee2MQTT but I don’t like the detour through third-party software.
It is also a science to control an RGB lamp, which was the only real technical problem for me, everything else worked right away.

I’m curious now about the Ember Stick, if it also makes problems, Zigbee2 MQTT will probably be reactivated. But which raises the question of migrating everything to Home Assistant.
In any case, I will prepare a final report.

Strange - what was the problem? The Qivicon stick is made by Bitron Video (or do you mean the older Qivicon stick that is a Telegesis dongle?).

Keep in mind that Qivicon also use the binding themselves - so I think it works fine with their sticks :wink:

It’s been 1 1/2 years ago, it was this one and I was a bloody beginner in OpenHab at the time. As far as I remember I needed your help to get the Telegesis online.

Sorry - I don’t remember back that far :slight_smile:

In general I would say that the Ember sticks are the best, and certainly the best supported since there are tens of thousands of users using the Ember dongle with my libraries and a lot less using the others…

No wonder with the many people you supporting here. :+1:
Have now read a lot on the subject and come to the conclusion that the Ember should be the best solution. Somehow I have long overlooked that the Bitronvideo ZigBee USB uses the Ember chip, otherwise I would have ordered it much earlier.

I can’t get any further, the Bitron Video ZigBee USB Stick has been there since Tuesday and since then I’ve been trying to configure my devices. I deleted all ZigBee Things, uninstalled the binding, shutdown the OpenHab VM. Then exchanged the stick, reconfigured in Proxmox and started OH again. Reinstalled the binding and was thrilled, all my lamps, dimmers, sockets, buttons, sensors and 2 Danalocks were found and also worked. The next morning only a few devices worked, mostly lamps. I then removed everything again and re-read it. Most lamps and dimmers are working, but among other things the Xiaomi sensors (00158D00022CC738) and also the Danalock (000B57FFFE46F14B) no longer work, they are found as “Unknown ZigBee Device”, have no “channels” and are offline. I don’t know what to do next, it looks to me as if the devices are found but then never answer again. Various changes to the settings on BV 2010/10 did not break any improvement either. With the option “allow all joins” everything got worse.
I have attached a log (is a .ZIP renamed to .TXT) with detection of the two devices described (Xiaomi was initially recognized as Lumi.sensor “00158D00022CC738”) & Danalock V3 “000B57FFFE46F14B” and hope that someone has a good idea.ZigBee.txt (624.8 KB)

Addendum:
I think the problem started with the CC2531, he also recognized a lot and the next day nothing worked anymore, at that time I thought it was the CC2531 and afterwards I also had problems with the Telegesis.
I also made a copy of the OH-VM and downgraded it to openHAB 2.5.3 Release Build. After that i cleared the chaches, but it didn’t work either. The log is from this machine.

Looks like most things are related to the OH database. On the test OH I have now deleted everything I found that is related to ZigBee and the previously installed Zigbbe2MQTT and now the Xiaomi sensors (Lumi.sensor) and the Danalock can be read in again and also work.

I believe, for either Zogbee or Zigbee2MQTT the support is directly in the binding. I know Z-Wave has a database for OH but not Zigbee. Even with Z-Wave there is a certain amount of support needed in the binding too.

Chris would you be so nice and take a look at this, please. After i was trying a lot, manually deleting the data and creating all ZigBee components, all 26 devices worked yesterday evening. Suddenly when I was doing something else, a snapshot backup was running in the background, the stick was displayed offline and nothing worked
(Logs in ZigBee_dies.zip). I then restarted the server and the devices that have no battery went online again during the night. The battery does not, however, except a “Philips RWL021 (0017880103293A2A)”. All XML’s in the folder “openhab2-userdata \ zigbee \ zigbee_coordinator_ember_01370A70” were empty except for the address (NOK.zip), I don’t know what that means. This state remained the whole day until I removed the dead devices and re-taught them (OK.zip).
There are a lot of exceptions in openhab.log from 22:58:39,

05-Apr-2020 22:58:39.260 [ERROR] [.openhab.binding.zigbee.handler.ZigBeeThingHandler] - 0017880106EA0C6D: Exception creating channels 
java.lang.NullPointerException: null
	at com.zsmartsystems.zigbee.zcl.ZclCluster.readSync(ZclCluster.java:1635) ~[bundleFile:?]
	at com.zsmartsystems.zigbee.zcl.clusters.ZclPowerConfigurationCluster.getBatteryPercentageRemaining(ZclPowerConfigurationCluster.java:804) ~[bundleFile:?]
	at org.openhab.binding.zigbee.internal.converter.ZigBeeConverterBatteryPercent.handleRefresh(ZigBeeConverterBatteryPercent.java:112) ~[bundleFile:?]
	at org.openhab.binding.zigbee.handler.ZigBeeThingHandler.doNodeInitialisation(ZigBeeThingHandler.java:404) [bundleFile:?]
	at org.openhab.binding.zigbee.handler.ZigBeeThingHandler.access$0(ZigBeeThingHandler.java:238) [bundleFile:?]
	at org.openhab.binding.zigbee.handler.ZigBeeThingHandler$1.call(ZigBeeThingHandler.java:232) [bundleFile:?]
	at org.openhab.binding.zigbee.handler.ZigBeeThingHandler$1.call(ZigBeeThingHandler.java:1) [bundleFile:?]
	at java.util.concurrent.FutureTask.run(FutureTask.java:266) [?:1.8.0_232]
	at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$201(ScheduledThreadPoolExecutor.java:180) [?:1.8.0_232]
	at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(ScheduledThreadPoolExecutor.java:293) [?:1.8.0_232]
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149) [?:1.8.0_232]
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624) [?:1.8.0_232]
	at java.lang.Thread.run(Thread.java:748) [?:1.8.0_232]
05-Apr-2020 22:58:39.261 [DEBUG] [stems.zigbee.app.discovery.ZigBeeNetworkDiscoverer] - 00124B000FFA51E6: NWK Discovery starting node rediscovery
05-Apr-2020 22:58:39.262 [DEBUG] [stems.zigbee.app.discovery.ZigBeeNetworkDiscoverer] - 00158D0001675E31: NWK Discovery starting node rediscovery
05-Apr-2020 22:58:39.262 [DEBUG] [.openhab.binding.zigbee.handler.ZigBeeThingHandler] - 0017880103293A2A: Start initialising ZigBee Thing handler
05-Apr-2020 22:58:39.263 [DEBUG] [.openhab.binding.zigbee.handler.ZigBeeThingHandler] - 7CB03EAA0A030E94: Coordinator status changed to OFFLINE.
05-Apr-2020 22:58:39.263 [DEBUG] [ding.zigbee.discovery.ZigBeeNodePropertyDiscoverer] - 0017880103293A2A: ZigBee node property discovery start
05-Apr-2020 22:58:39.263 [DEBUG] [tsystems.zigbee.transaction.ZigBeeTransactionQueue] - 00158D0001675E31: Queue shutdown

could the problem be related?
I’ve been trying to get my system stable with the Ember Stick for 5 days now, but I’m slowly despairing.NOK.txt (63.9 KB) OK.txt (84.1 KB) ZigBee_dies.txt (452.9 KB)