Wifi LED-Binding cant change colors

Hey all,

i have now two days my openhab2 on my rasberrypi 3+ installed.
I’ve bought some RGB-Bulbs from Amazon -

LINK: https://www.amazon.de/gp/product/B07D3SKBT3/ref=ppx_yo_dt_b_search_asin_title?ie=UTF8&psc=1

They are controlled by Magic Home App and everything works fine.

So I already red many about the Wifi-led-binding Addon from the OH binding section.

I manually added the Things for the wifi LED:

Thing wifiled:wifiled:C44F339B1EAE [ ip=“”, port=5577, pollingPeriod=3000, protocol=“LD686”, driver=“CLASSIC”, fadeDurationInMs=1000, fadeSteps=100 ]

This works fine, with a Switch, but not with the color Option…

If i want to change to for example to red color, nothing happens.

2019-10-03 21:11:08.253 [nt.ItemStatePredictedEvent] - WiFiLEDColor predicted to become 142,83,100

2019-10-03 21:11:08.266 [vent.ItemStateChangedEvent] - WiFiLEDColor changed from 60,100,100 to 142,83,100

So OH says, its fine.

In my .items file there is the following

Switch   WiFiLEDPower          "Power"           {channel="wifiled:wifiled:C44F339BD5499:power"}
Color    WiFiLEDColor          "Color"           {channel="wifiled:wifiled:C44F339BD5499:color"}

Im using the Colorpicker in the .sitemap file:

sitemap home label="testingl" {
    Frame label="just testing" icon="icon" {
        Switch item=WiFiLEDPower
        Colorpicker item=WiFiLEDColor

If you add the LEDs from the PaperUI, i can see all channels, like power, color, white, white2, program and programSpeed.

I’m using OpenHab2 2.4.0.-1

AND= Colorchange works with Alexa…

Maybe anyone has an idea?
Thanks in advance!!!

Please use code fences whenever posting code, logging or configuration.

In question of the Wifiled, are you sure about the protocol?

Hey there, yes I’m sorry, i will correct that. Its markdown linting?

I tried the LD382A protocol, but this didnt work, too.

And no, im not sure with the protocol…
Do i have a chance with wireshark, to log the network traffic and see, what magic home is using?


Isn’t this bulb a Tuya device with a esp8266 ?
When I google for it it seems like. Not sure. But wifi and a very cheap price…

If so, search this forum for ‘Tuya mqtt’ and you will find info about how to.


thanks for this fast answer.

I willl look to this! And i will report if i can run/fix it, with the mqtt…

Here the topic


Read carefully especially the last few month. There were some changes overtime.

It dont seem like they are tuya devices. If i add a new thing via Wifi-LED-Binding, i can find all of them.
And as i said, i can switch them on/off with this Addon…

So, i was so focused, that i figured out, with the tool " Packet Sender"
i can change colors,

41 00 05 ff 00 f0 0f 44 is blue
41 ff 00 04 00 f0 0f 43 is red
41 00 ff 0a 00 f0 0f 49 is green

It is a Hex-Value, but i do not have any special knowledge about hex-values.

Maybe some ideas?

Sorry can’t help with sending raw HEX data.

But it look like 2th till 4th data is for the color.
FF = 255 ( decimal ) Full On
00 = 0 ( Decimal ) is Off

range between 0-255 is a normal value for RGB color’s as every color has normally a 8 bit value for brightness.

So when you look at the hex string for blue…
( 41 00 05 ff 00 f0 0f 44 )
41 = maybe a bulb ID ?
00 = Color Red ( its OFF )
05 = Color Green ( its a bit there like 2% )
FF = Color Blue ( Full ON )

The rest of the data no idea.
Hopefully someone with experience with these bulbs can help you.


Hey there,

I was thinking exactly at the same… at the moment, I cant dig more into it… But i will continue maybe at the weekend.
Anyway, thanks!

Hi - Was there any further progress on this? I’m in the same position (I have a Wentop Wifi LED and as per @pvtsrk , I can turn on and off with OpenHab WiFiLED Binding, but nothing else)

OK - I’ve fixed this. My issue was that I needed to define the thing in a .things file, not in the Paper UI. Not sure why. My .things file:-

wifiled:wifiled:testLED "Text Bedroom LED" @ "LED" [ ip="", port=5577, pollingPeriod=5, protocol="LD382A", driver="CLASSIC", fadeDurationInMs=1000, fadeSteps=100 ]

Hope that helps someone else…

1 Like

had the same Problem. For any reason creating Thing in file instead of UI solved the Problem ! <3
running openHAB 3.2.0