Wifiled does not contain manifest

  • Platform information:
    • Hardware: celeron N3450 / 4GB / 184GB
    • OS: Linux Mint v19
    • Java Runtime Environment: zulu 1.8.0_172-b01
    • openHAB version: 2.3 (release version)

I’ve just installed a fresh copy of OH on a clean install of Linux Mint 19, which will replace the version I’m currently running on different hardware.
Everything has installed OK, apart from the wifiled, which won’t install.

The OH log says it failed because ‘does not contain a manifest’.

I’ve found the same error mentioned on these forums, but nothing mentioned in that other topic has been able to sort my issue.

Does anyone have any ideas please?


As I said, found the same error mentioned on these forums, but nothing mentioned in that other topic has been able to sort my issue.

And anyway, uninstalling is the same as what I already have.

I want installed, not uninstalled.


You have read that and tried out?

yep.

“nothing mentioned in that other topic has been able to sort my issue.”

then you are doing something wrong
the solution posted above works (it worked for multiple users)

The other files I have in ‘addons’ work without problems. That 2.4 snapshot file did not.

PS: I have a 2.3 release installation on another machine, where wifiled works perfectly.

It’s very annoying that the good files are not locked into a release! (a problem i’ve encountered before).

You don’t need to manually deploy the wifiled binding as a jar in the addons folder
Since you are running 2.3 stable, clear the cache & tmp and install the addon using PaperUI
Maybe? the snapshot version of the wifiled binding has a problem? (I haven’t checked)

I do if if I’m trying the 2.4 snapshot, as advised in that other topic (which as I said, didn’t work).

tried that tens of times - it just hangs on installing, and the log gives the error which I started this topic about.

it’s the 2.3 release version has a problem.

And the suggestion of trying the 2.4 snapshot version doesn’t fix it.

the advise to use the 2.4 snapshot version was an intermediate solution until the 2.3 stable version of the wifiled binding was fixed on the online repo.

From what I know, the 2.3 stable version was corrected and if you clear your cache & tmp and let OH2 re-download the binding, it should work… make sure that cache & tmp are properly cleared.

I will check the 2.3 stable wifiled binding on the online repo but I don’t expect any problems.
I already checked the jar for the 2.4 snap and it’s ok

I installed (and cleared, then tried again) via apt about 10 times last night - the one in the 2.3 distro doesn’t work.

did you remove (with rm) the contents of /var/lib/openhab2/cache + /var/lib/openhab2/tmp ?
apt will not take care of them (only apt-get purge will)

I’ve uninstalled with purge, made no difference.
I’ve deleted the cache & tmp files, made no difference.

I’ve just stopped OH, deleted the cache & tmp files again, put the 2.4 snapshot jar in addons, and this time it’s worked … but I’ve no idea why it didn’t last night, with multiple tries.

It’s simple: It’s VooDoo ! :slight_smile:

what’s voodoo is distributions marked as the same release number that contains different files depending when you download it.

That’s nuts, and not something I’ve encountered with other software in 30 years in IT!!

??? more info are needed :stuck_out_tongue:

I have 2.3 release version installed on one machine (done within a few weeks of 2.3 being released), where wifiled works perfectly.

The current 2.3 distro has the dodgy version you know about.

That can only be because the files are not locked into a release.

The files are locked into a release
the current 2.3 distro had a problem with 1 binding due to a broken build for that binding (one out of hundreds)
the problem was resolved immediately
the current 2.3 stable version of the wifiled binding works just fine
try to deploy it manually to see if you get the same error: https://dl.bintray.com/openhab/mvn/online-repo/2.3/org/openhab/binding/org.openhab.binding.wifiled/2.3.0/
If it gets stuck when installing it via PaperUI then something else maybe wrong (download gets corrupted somehow?)

Not true. It’s twice now I’ve been able to install jars OK on one day with the release version, but not on another day, and where the fix is a newer jar.

not true.

I installed with apt last night multiple times, and the wifiled binding gave the manifest error.