Wifiled (Wifilight) Binding

Does anyone know why the binding disappeared from the plugins repo?

Hello!

I’m running OH2 build 798 nightly and it is listed in the bindings. What build are you using?

Best regards,
Davor

I have it installed from apt, so the latest one from there. I’m not at home to check exactly.

Hello!

If I’m not mistaken, WiFiLED binding is included in the latest openHAB2-Bundles (19.02.2017 8:58:46 PM) on CloudBees. I’m not sure which build apt uses, but latest OH2 build failed, so, maybe that’s the problem.

Best regards,
Davor

I’ve installed OH by downloading the rpi image as well, and I can’t see WifiLED in Add-ons -> Bindings either. Is it possible to install the binding manually?

Not sure whether this will help, but the snapshot repo has moved:


I have installed the snapshot from this weekend from this new repo and the wifiled binding is there

Thanks @lipp_markus, found it after updating!

Hello guys,

anyone who can tell me how to setup my wifilight RGB stripe controller? Can’t set a startup color, brightness and saturation.

Did you find a solution for the high pitch noise? Mine does that too and it’s driving me nuts.

Hello!

I’ve just squeezed it in various spots, and that made noise a lot less annoying. It doesn’t have to be totally quiet, because I have other stuff making noise. It just has to be under that threshold.

Best regards,
Davor

Okey will try to squeeze it a bit :slight_smile: Otherwise I’ll try to add some sound absorbing around it.

Love this binding… quick question though…

I’m trying to control a mixed white led string. The warm leds are on the white channel and the cool leds are on the white2 channel.

The way to control the temperature of the lights is by a combination of the two channels (e.g. 10% white, 25% white2).

I’m trying to set the channels in series. It would look something like this:

if (KitchenCabinets_power.state == OFF) { KitchenCabinets_power.sendCommand(ON); Thread::sleep(50) }
KitchenCabinets_white.sendCommand(new PercentType(10))
KitchenCabinets_white2.sendCommand(new PercentType(25))

My thing is configured as:

Thing wifiled:wifiled:F0FE6B2319F0 [ ip=“192.168.0.123”, port=5577, pollingPeriod=3000, protocol=“LD686”, driver=“CLASSIC”, fadeDurationInMs=1500, fadeSteps=100 ]

My items are configured as:

Switch KitchenCabinets_power “Power” {channel=“wifiled:wifiled:F0FE6B2319F0:power”}
Dimmer KitchenCabinets_white “Warm White” {channel=“wifiled:wifiled:F0FE6B2319F0:white”}
Dimmer KitchenCabinets_white2 “Cool White” {channel=“wifiled:wifiled:F0FE6B2319F0:white2”}

Everything works ok individually, but when I try to execute as above, the warm lights come on first, then shut off as the cool lights come on. (white comes on, then shuts off when white2 comes on)

Anyone have any ideas?

I have seen the something similar when making my own ‘sunset’ fader (30 minute fader from orange to power off). When I fade white and RGB at the same time the white starts to flash going off and on.

I might have a fix for that. If you are interested I can send you a compile jar you need to put in your addons directory.

Ries

Heck yea I’m interested

Do I need to compile your github fork or can you send the compiled jar? (I’d have to figure out a way to get you my email address privately.

I have uploaded it to my server.

http://vantwisk.nl/~rvt/org.openhab.binding.wifiled-2.2.0-SNAPSHOT.jar

This version also has an updated fading driver that should lower CPU usage and play a bit more nice during updates while fading is still in progress.

You need to dump it in your addons directory… Not sure if you need to do something on the openhab terminal anymore but ping me if you have issues.

So far, it seems to work great! Not fully implemented yet, but early tests work perfectly.

Man I owe you one! Thanks

Not fully implemented yet, but early tests work perfectly.

Honestly I am only using the fading driver and classic driver to set my colors…

What is not fully implemented yet?

Not fully implemented meaning I haven’t updated all of my rules yet to work with the new capabilities. But I’m working on that now.

I’m interested in the fading driver also. I use mine to control kitchen cabinet lighting. At dusk, the lighting turns on at 50% brightness. As the night rolls on, the brightness decreases, until midnight when the brightness settles on 2% for the overnight hours.

But, I have a motion sensor in the kitchen as well. So if the wife gets up in the middle of the night for water or something, the cabinet lights increase to 35% so she can see. But without the fading driver working right before, the transition from 2% to 35% is quick. I’d like to slow that down a bit for more of a natural fade transition.

Do you have an example of how you’re using the fading driver that you can share?

Again, thanks for your work on this. It has been on my back burner until I could get time to dust off my JAVA skills and get around to work on it myself.

I’d like to slow that down a bit for more of a natural fade transition.

You can tell the fading driver to setup a fading duration with a fading steps.

I have these LED’s behind my bed and setup to fade from 10% to 0% over a period of 30 minutes. Obviously the fading driver won’t work with such a long fading periods. So make this work I created a rule for this and setup a scheduler to do the actual fading. The reason I had to modify the driver because of the flashing when setting color + white’s at the same time.

I can share my rule for that, but allow me some time to create this as a script and add some documentation to it…