Windows 10 firewall

Hi all

I am just taking my first tremblig steps in the open hab world and I have a really silly question, but yet I have not found an answer:

  • How the heck do I configure the windows 10 firewall to accept incoming calls from other than the local host?

I have tried to open port 8080 in the windows firewall. I have checked the port usage with CurrPort and it is indeed 8080 and nothing else is running on it. As soon as I turn on my Private firewall zone I can’t connect from either my laptop nor my ipad app. I just dont get it it should be suficient to just open the port what am I mising?



Interesting have no one had this problem? I don’t feel comfortable to have the firewall turned off and I have tried the things I can come up with. Well I just have to wireshark it and see what ports that opens up, but I find it strange in such a big forum that no one can help me,



why to “wireshark it” ? OH2 opens up 8080 for http and 8443 for https

The forum deals with openHAB related topics, not windows 10 firewall and how to configure it.
For this: google is your friend !

Gahhh, windows firewall does not behave as expected. I’ll ouline below what the problem was, but first some info on my rule:

The rule was a very wide one no fancy stuff like program restriction or other stuff, only a simple rule that opened port 8080. The most simple one.


  • When debugging the second time I notived that it was not the private profile that blocked the call, but rather the public one which was strange I am behind a firewall.
  • I confirmed it in an elevated cmd: “netsh advfirewall show currentprofile”
  • I changed it in an elevated poweshell:Set-NetConnectionProfile -name “network name” -networkcategory Private
  • voila it worked.

There is one lesson learned. When you turn off the sharing functionality in win10 the network profile will be set to public.
The other is the strange behaviour that the rule that was configured for all profiles, to open port 8080, did not open when the network profile was public even though it should have.

In short: make sure your network is in private mode

1 Like