Working VPN - but can't access openHAB

Hej there, as I wanted to access openHAB remotly, I configured a VPN connection on my router, which is a Fritzbox.
I’m able to successfully establish a connection from my android device. But I cannot access openHAB; not by webbrowser nor by the native app.

I tried:
(Ping and port scan possible though)

After a while webbrowser stops loading with message: Site can’t be reached - ERR_CONNECTION_ABORTED - And the URL shows as follows: >> http://hostname:8080/start/index

If I remember correctly I had it up and running a few month ago.

What I should mention: While connected through VPN I can access other devices in my netzwork (like hue bridge, oder network camera).
So I guess this narrows the issue down to the server running openhab. But this is where I get lost. I don’t know where to start. I couldn’t even find related logs in /var/log/messages

Thank you for your input.

  • Platform information:
    • OS: CentOS Linux release 7.6.1810
    • openHAB version: Version: 2.5.6 (Build)

firewalld.service - firewalld - dynamic firewall daemon
Loaded: loaded (/usr/lib/systemd/system/firewalld.service; disabled; vendor preset: enabled)
Active: inactive (dead)
Docs: man:firewalld(1)

Are all the other devices and OH in the same VLAN and IP range ?
Start wireshark or any other network sniffer on your OH host and check if there are incoming connections.

Hej @Wolfgang_S , thank you for your reply. I run just one (non-virtual) network, all IPs are within range.

I did some more tests and I have to correct my initial statement.
When I am connected to my local Network through VPN, I can access some devices but not all (including the server running openHab2) … PING is possible though. I also can’t control my hue lights (Within hue app I get the message: can’t connect to bridge). Accessing the web interface of my LAN-Camera is possible for example.

That being said, I don’t think its a server problem, like I initially assumed. Looks more like a VPN/Router issue atm.

Again, thank you for your input.

1 Like

If you use basic VPN support of a fritz box I doubt that the problem is with VPN/Router itself.
As far as I know Centos 7 uses SELinux could that be the problem - although then you also would see the problem in your local network.

Again I would suggest to run a network sniffer on the target machine. At least you should be able to see incoming connections. In case parts of the initial connection work you could trace the http traffic.