Worx Landroid Binding

I have reinstalled the binding and it works

That are very bad news :sob:

@nibi79, it may not be appropriate to ask, but is there a specific reason?

Would it be possible to at least push it to the official openHAB marketplace?

That wouldn’t help much with future updates, but at least the users would be able to find the binding in a common place.
At the moment we have to look through hundreds of posts in the forum to find that one link to a private file cloud service … (Thx @glhopital for providing this)

1 Like

I downloaded the version from google disk, but when setting up the bridge,
I get the error getting access token error
As I understand it, the version is not working?


openHAB 4.1.1 Release Build

That version is working fine here on openHAB 4.1.1.

Edit: I don’t know where you’ve found that link, try the one from a couple of posts above…

I downloaded from the link a couple of posts above.
I tried to restart openhab - it didn’t help:(

I do not know what happened, but the binding became online

The binding seems to work (bridge and mower are both „online“) and shows all values, but starting the Landroid is not possible and no data is ever refreshed. Only a restart of the things fetches the current data, but as said, there is no automatic refresh. Any idea?

Sending the String START to the common#action Channel works fine here with binding version 4.1.0 snasphot on openHAB 4.1.1 Release.
Also STOP and HOME are working fine on the same Channel.

Did you already try to restart openHAB or even the server? This usually works fine if no refresh is available, though I have not yet experienced this with the Worx binding.

1 Like

@nibi79, sorry to bother you again, but you don’t give any answers here in the forum nor on the github issues …

Did you abandon the Worx binding?

At the start of the new mowing season I updated my OH to 4.1.2. The installation of the Landroid binding worked even after inserting the default values into the map files.
The data is also retrieved from the API, but not written into the items. Some names and formats are said to have changed. But which ones are they?
Originally I copied the items from NIBI’s Github documentation and that also worked on OH3.4.4 but now nothing works in OH4.1.2.
Would be grateful for any help.

Some of them are listed way up in this thread, for example:

Mostly Numbers are Strings now.
You need to delete both Things and readd them to see the new Channels and Itemtypes.

@ sihui: Thank you for putting me on the right track again. I’ve been in panic, to hunt the whole API-String to find the correct channel-names to change in my items-File. :cold_face: :man_facepalming:

1 Like

Hi!

Today I’ve tried to enable my binding but I’ve got the same error as @CKB. I’ve removed both Things, removed binding, erased cache and restarted. I’ve installed the latest binding jar again, and tried to connect but I still have the same error.

Log:

2024-03-29 14:04:14.076 [DEBUG] [al.handler.WorxLandroidBridgeHandler] - Initializing Landroid API bridge handler.
2024-03-29 14:04:14.079 [INFO ] [ab.event.ThingStatusInfoChangedEvent] - Thing 'worxlandroid:bridge:worx_api' changed from INITIALIZING to UNKNOWN
2024-03-29 14:04:14.116 [INFO ] [ab.event.ThingStatusInfoChangedEvent] - Thing 'worxlandroid:bridge:worx_api' changed from UNKNOWN to OFFLINE (COMMUNICATION_ERROR): Exception in oauth communication, grant type password

Any other workaround? I’m connecting from Hungary if that is relevant.

Thank you.

You have to either restart openHAB or restart the worx binding (without removing the things). Then it should work again.

Hi @Spaceman_Spiff,

I’ve done both, but did not help. App worx as expected :grin:

Make sure you have the correct version from 30. October 2023:

openhab> list -s | grep worx
244 │ Active │  80 │ 4.1.0.202310301404     │ org.openhab.binding.worxlandroid
1 Like

Thank you, that was my problem.
The latest version by this post date (4.1.0.202310301404) can be found on someone’s Google Drive: here. For others’ reference.

1 Like

Hi all,

same on my side - no password change since months, latest binding installed since months.
Any fix known?

Best

Thats somehome strange, I’m running the latest version, and since 3 weeks the mower is doing his job again after the winter brake → the binding worx perfectly, I have not faced a single issue since the last update

I removed the binding file from the addon folder. When the things where de-initialized in the log, I copied the binding file back to the folder and the bridge works now.

Unfortunately the charging station has an issue and I had to hand in the mower, so no feedback on this thing but I am optimistic.

Please help me!
I would have sent the robin out to graze for the first time today…
I am using OH 3.3.0 and it would be difficult for me to switch to OH 4.
I updated them all to the “mauerj 3.4.6-fix99” Binding version, which worked perfectly in the fall. Now I get “COMMUNICATION_ERROR” error.
My question is, is there currently a working Binding for OH 3.3.0? Has the communication changed causing this error?
Thanks in advance!