Worx Landroid Binding

I can get updates when requesting the aws poll, I assume no block! Polling interval is set to 3600 anyhow.

Do I need to send 1 / 2 or “NORMAL” / PARTY"?

Follow the link I gave you. There is an example …

sorry, I have overseen the hidden details, I tried with 1 / 2 and it works again.

1 Like

always as string, but we send 1 or 2 but updates or binding update the item to NORMAL or PARTY.
I would expect when I send 1 or 2 I get 1 or 2 from an update. Or when I get NORMAL or PARTY from an update, I have to send NORMAL or PARTY to the item too.

At the end of the day, I can life with it but it think there is an inconsitency.

How is your item declaration?

mine is
Switch item=LandroidScheduleMode mappings=[1="Normal", 2="Party"]
but Normal or Party is never selected, because I send 1 or 2 to the Item but get NORMAL or PARTY with an update of the item.

String Worx_ScheduleMode "Mähmodus" (gRestore) {channel="worxlandroid:mower:mower:m500plus:schedule#mode"} //1=Normal, 2=Party

Selection item=Worx_ScheduleMode mappings=[1="Normal",2="Party"]

As long as it works I don’t care :laughing:

I am using the binding 4.1.0.202310301404 (latest as I know) on m OH 4.1.2.

Regularly (several times a day) the worx bridge goes offline “Exception in oauth communication, grant type refresh_token” while the mower stays online (but can not be operated)

Bridge

UID: worxlandroid:bridge:aaa
label: Bridge Worx Landroid API
thingTypeUID: worxlandroid:bridge
configuration:
  password: xxx
  username: yyy

Mower

UID: worxlandroid:mower:aaa:bbb
label: Landroid Mower
thingTypeUID: worxlandroid:mower
configuration:
  pollingInterval: 3600
  reconnectInterval: 300
  serialNumber: "xxx"
  refreshStatusInterval: 1200

Any hint?

There is no option reconnectInterval (anymore).

It looks like you updated the binding, but forgot to update the Thing: delete the Thing an readd it again.

configuration:
  pollingInterval: 3600
  refreshStatusInterval: 1200
  serialNumber: <serial>

I recreated both things fully from UI. The mower stays online but the bridge goes offline aftter around have a day: “Exception in oauth communication, grant type refresh_token”.
When I pause and restart the mower thing while the bridge is offline, the mower gets an error that the bridge is offline => makes sense.
When I pause and restart the bridge, the bridge works fine again.

Bridge

UID: worxlandroid:bridge:aaa
label: Bridge Worx Landroid API
thingTypeUID: worxlandroid:bridge
configuration:
  password: bbb
  username: ccc

Mower

UID: worxlandroid:mower:xxx
label: Landroid Mower
thingTypeUID: worxlandroid:mower
configuration:
  pollingInterval: 3600
  refreshStatusInterval: 3600
  serialNumber: "yyy"

I would try to clean cache and tmp folders. Apart from that I don’t have any more ideas …

I installed binding yesterday.
Bridge and mower are online … all items works … but without update.

Restartung openhab ends in an update for the items … but only once.
How do i get the binding updating.

I use 4.1.0.202310301404 of binding.
Refresh Status Intervall = 60
Polling Intervall = 300
Regards.

1 Like

That interval is too short, it will ban your Worx account within hours.

Does your Worx smartphone app show the actual time stamp and status?

I am having the same issue for many months now without finding a solution. Also with higher Polling Interval and all recommended settings it is sometimes working for some days after a reboot, but then the same issue comes back until the next restart.
Finally I gave up using this binding until hopefully a new version comes up and am using my lower with the original Landroid app until then. :cry:

Strange, it is working here without any problems.

I also have the problem with the update. I installed the current binding in the spring and get current data when I switch the mower offline - online.
I have a question about the channels. What are these two channels for?

  • Poll AWS (aws#poll (Switch))
  • Connected (aws#connected (Switch))

How does the status have to be correct here?

If the binding is connected to the Worx api, the switch is ON. You only get item updates when the switch is ON. It is a read only channel.

If you switch it to ON, data gets pulled from the api. If you switch it too often, your account gets banned for 24 hours :grinning:
It overrides the Polling Interval.

Thank you!
I had the Poll-AWS switch set to permanent true.
As I understand it, polling occurs exactly once every time you switch on?
No matter how long the switch is ON.

Yes.

Yes.

If you don’t use that switch, polling occurs every time the Polling Interval is set to (in seconds)

I always get connection lost or banned with those parameters:
refreshstatusintervall: 1200
pollingintervall: 3600
What should I change?