Worx Landroid S with openHAB

Tags: #<Tag:0x00007f61700effa0> #<Tag:0x00007f61700efe88> #<Tag:0x00007f61700efd98>

The Code from MeisterTR is for ioBroker, can i usw. it for openHab?

I have this installed

Im not using openHab, but data is stored in an SQLLITE database as i can see, so you need to read this data somehow with a driver from OpenHAB.

I’ve already wondered, this is for openHab and not for ioBroker.

you misunderstood me, that was not a criticism that you post something of ioBroker in this forum here, but that I was amazed that it runs differently with you as openHab with me. That you delete your posts now I find childish and pity.

1 Like

HI,

I like to stop my e-Dolly once in accident green irrigation was initiated while shaun is out there. As shaun can’t get home any longer because of valves open close to wire I just like to stop shaun where it is with landroid/set/mow but this command doesn’t work for me :-/

Anyone having this running???

Getting the same error here, which issue did you open? Have you found a solution in the meanwhile?
Thanks,
Stefan
[edit] Nevermind, found it out myself. Error goes away when mover is started and connected to app.

1 Like

Hi @virtualzone,
are there ideas to adapt the bridge to the new ioBroker.worx component of MeisterTR (https://github.com/MeisterTR/ioBroker.worx)? I think further development is only going on in the new worx adapter.

Hi all. I’m not sure if this is the right place to ask, but since iobroker has the best integration tool with Landroid-S, I hope than someone can answer. I’m trying to find the terms of service of the Landroid-S lawn mowers api, but I can not find anything. In the german forums there are post about Worx complaining about the abuse of the api, but I dont understand German and even with google translate everything is very confusing to me.
Bluestacks Lucky Patcher

AFAIK there’s no “official” API and so no terms and conditions to use it. The use of the reverse engeneered API is tolerated.

Hi,
there was no error. I like to stop shaun by sending a request, which fails :-/
Have you managed to stow your mower?

Regards
J.

I only use Worx app to control the mower. I do use the binding to switch on/off power one hour before / one hour after scheduled mowing times to save unnecessary loading cycles.
If you are able to detect that mower us returning home and watering is on, you might send a message to your phone and switch off the mower manually.
I have my irrigation times set early in the morning whereas the mower starts 4 hours later that all is dry before he starts mowing. I have two separate mowing areas which are not connected and need manual placement of the mower which is very bad for holiday situation. So I can’t rely on everything being automatic. I only once had the situation which you describe in your scenario that watering was switched on manually while the mower was working in the area. He was able to get around the sprinkler not in the first try but after detecting his route is blocked he set back and drove around it. Have you ever tried the behavior?

Has anyone run this on an isolated IoT LAN without internet connection? I am looking to move my mower off the internet and control it through openhab within its own LAN.

That won’t work. The mower relies on cloud connection for all remote operation. Even over MQTT it will use the cloud.

Darn, I was hoping I could move all of my IoT off the cloud with MQTT commands. Still, OpenHAB will still be better than the apps!

Bridge seem to stop working again as Positec (WOrx) changed API this year, hope Bridge will be adopted soon as I loved to have all managed by one system.

Does anyone have any news on the bridge? Has anyone been able to get in touch with Heiner?

I don’t :frowning:

I discovered https://www.iobroker.net/ where there’s an excellent solution for Landroid Worx (and many other things). I highly recommend it.

iobroker looks OK, but as I personally already use OpenHab (which btw I do highly recommend) I’m looking to integrate Landroid into this and as this already works with landroid-bridge (which used parts of iobroker) I’m looking forward that this is getting working again. Just need the programmer back to work on this :wink: