Wrong configuration after device reset

Hi There,

because I got some problems with one Z-Wave device i’ve reseted it to factory defaults and add it as a new Thing to OpenHab. The “old” device got Node ID 6, the New Node ID 8.

But obviously, the Thing wasn’t completely deleted.

I’m receiving the following errors:

2016-10-02 15:25:09.967 [WARN ] [ome.core.thing.internal.ThingManager] - Cannot delegate update '100' for item 'Battery_Multisensor_GF_Bath' to handler for channel 'zwave:device:d90ead21:node6:battery-level', because no thing with the UID 'zwave:device:d90ead21:node6' could be found.
2016-10-02 15:27:17.721 [WARN ] [.rule.jvmmodel.RulesJvmModelInferrer] - Duplicate field: 'Battery_Multisensor_GF_Bath'. Ignoring 'org.eclipse.smarthome.core.library.items.NumberItem'.

(I’ve created the Item Battery_Multisensor_GF_Bath for Node ID 8 using an Item Definition.

I’ve tried to delete the old Item manually using habmin, but the backend receives this message:

2016-10-02 15:28:05.057 [INFO ] [thome.io.rest.core.item.ItemResource] - Received HTTP DELETE request at 'items/Battery_Multisensor_GF_Bath' for the unknown item 'Battery_Multisensor_GF_Bath'.

How can I delete the old item?


If I understand the first warning correctly, node 6 is still sending updates so is still alive?

How are you configuring the system - through text files or UI?

Node 6 and Node 8 are the same devices. PaperUI shows me Node 6 in the Inbox and Node 8 in “Configuration > Things”.
As I’ve just found out, Updates to Node 8 are not properly delegated to linked items. Maybe I have to remove Node 8 and include Node 6?

I use the UI for adding devices and the config files for linking them. Maybe I’ve created the item linked to Node 6 using the UI .

Yes, but only one can be active - the same device can’t have two node numbers. From the log it looks like node 6 is sending data, which means node 8 should be deleted?

Node 8? The error above is for node 6, or have you changed something since the original post?

Yes - I would delete node 8, do a discovery (don’t touch the device, just click the discovery button and devices should be added back in to the inbox).

Maybe - I know that when devices are deleted, the links can remain -:

-: this might be part of the reason (maybe!).

Alright, so I’ve deleted Node 8 and Added Node 6. Then I’ve seen in the Logs, that Node 8 is sending messages. So I deleted Node 6.

Now have a look on my Inbox:

It’s unclear to me which of these is alive so first we need to be sure… I suggest the following -:

  • Delete both node6.xml and node 8.xml
  • Restart the binding, clear the inbox, and do a discovery again
  • Both devices will likely be back in the inbox, but hopefully only one will have a meaningful name
  • Add the device that DOES NOT have a proper name (it should say Unknown or something)
  • This will create a thing for the device and we can then try and get rid of it from the controller
  • Select the thing, select the tools menu in HABmin, and select Advanced mode
  • You should then have an option to “Set device as FAILed” - select this
  • You should also have an option to “Remove device from controller” - select this

If the magic works, the device should be gone and if you remove the thing, and do another discovery, it hopefully won’t come back! Unfortunately I’m not 100% confident since removing devices like this requires that the controller itself thinks the device is FAILed and for battery devices especially, it can be hard to convince the controller that this is the case.

Good luck :wink:

Thank you for your support.

Unfortunately, your advices didn’t work - It can’t remove the node from controller because it can’t find the node.

2016-10-02 17:44:05.520 [DEBUG] [message.RemoveFailedNodeMessageClass] - Got RemoveFailedNode response.
2016-10-02 17:44:05.521 [ERROR] [message.RemoveFailedNodeMessageClass] - NODE 6: Remove failed node failed as node not found

Is there something like a hard reset for the controller? I’ve got only 5 Z-Wave devices so re-adding them would be easy.


You can reset the controller completely using the “Hard Reset” option. Select the controller in the thing list, select advanced mode in the tools menu, and you should see an option “Hard Reset Controller”.

1 Like

Thank you for your great help - this solves the Problem. :slight_smile: