XBMC binding and openelec

Has anyone successfully used the XBMC binding with openelec? I’m having connection failures - presumably because I’m using the wrong json/websocket ports and/or the wrong username and password…



Yes, OpenElec seems to have a different default port, can’t check now but instead of 80 it’s 8080 or the other way around.
But you can also change this from within Kodi itself: Settings -> Services I believe.

thanks - unfortunately I tried that without success.

My current settings are:

# Hostname / IP address of your XBMC host

# Port number for the json rpc service (optional, defaults to 8080)

# Port number for the web socket service (optional, defaults to 9090)

# Username to connect to XBMC. (optional, defaults to none)

# Password to connect to XBMC. (optional, defaults to none)

The easiest way to test this is to use a kodi remote app on your phone.
Most of them have an autodetect feature.

Another reason can be that the remote control setting in Kodi isn’t on:
http://kodi.wiki/view/Settings/Services#Webserver and the following step.

I had issues getting mine to work without a password, once I added one it works fine. It also wouldn’t connect to my sql server without a password.

Hmm I tried adding a password, didn’t fix the connection problem. The Yatse app (alternative to the official xbmc app) works fine on port 8080, though. Are the default settings of 8080 and 9090 even valid for OpenELEC?

I too am unable to get this to work.

I get no connection errors but this odd message in the log:

Attempted to register a second BindingConfigReader of type 'xbmc'. The primaraly reader will remain active!

and my items don’t work.

My cfg file reads:


And my items file:

String OpenelecState "Openelec state" {xbmc="<[#living|Player.State]"}
String OpenelecType "Openelec type" {xbmc="<[#living|Player.Type]"}
String OpenelecTitle "Openelec title" {xbmc="<[#living|Player.Title]"}
Switch OpenelecPlayPause "Openelec play-pause" {xbmc=">[#living|Player.PlayPause]"}
Text OpenelecNotification "Openelec notification" {xbmc=">[#living|GUI.ShowNotification]"}

Has anyone managed to get the xbmc binding working reliably with openelec?

i got the latest version working on the rpi

the rsPort is the one you can configure in the settings /services/webserver
i put mine on 8084
the ws port is standard 9090 and you must not change it
login and password are also the ones you configure in the settings /services/webserver

problems i’m having is that with the new 6.0 version not all data is correct.
i cannot get the showtitle for example.
play /pause works, episode title works and … i think the binding needs an update for the new version of kodi.

kindest regards


i’m having an issue with the binding in not sending the player.Showtitle , i believe that in the new kodi application some commands changed.
can the dev please look into this in future releases ?

kindes regards