Xiaomi Items not getting values

Hi all,
I’m really hoping you can help.
Been using Openhab for a couple of years, and love it.
Since about December though I cannot get the Xiaomi stuff to work and it is really puzzling me!

The bridge is online, and the items themselves are also online. I even deleted all the items and started again, and they are all autodiscovered fine, and add fine, and then also show up as online. I have entered developer code etc.

The issue is they dont actually get the information through. They seem to detect the battery low, and also the battery amount, but that is it. They dont report motions or door opening depending on the sensor. They do however report it all in the app so the sensors are fine.

There is nothing in the error or event logs, so I am assuming the gateway isnt telling openhab, even though they are all showing online. I have even used a new SD to make a fresh install, and again same issue, nothing coming through.

The only exception to this seems to be the Humidity sensor gives a value.

I would really appreciate some help as this has killed my Smart Home setup.


Hi Scott,

Have you set the log to DEBUG or TRACE to see if there is any additional info that may help identify the issue?

Do I need to type in this to enable that: log:set TRACE org.openhab.binding.xiaomi

Docs are your friend :grinning:

Yes, enter that from the Karaf console and you will need to set it back after you get the info.

Thats where I looked and typed that from, I was asking if it was right before I type it in a screw something up

Is it Xiaomi or mihome on the end?

Can you look in the binding to see. Or in karaf i think usinig ```
openhab> bundle:list | grep openHAB

will show all your binding.

The bundle thing didnt work, just gave a list of the services/actions not the bindings, but i think its mihome so tried that. Where will the log save? in events?

Ive looked in events but theres nothing there

I’ve done the log thing correctly, and checked mihome is set correctly to trace, but there isnt a single log entry for mihome showing up

From the webUI remove :8080 and replace wiith :9001 for log viewer

Try uninstalling the binding then reinstall

Done that, and tried a fresh openhab install too

Sorry, not much more I can help with. Try a search for a similar issue and maybe you’ll run across the answer.

Best of Luck

Does the devices work (report) correctly to the Mi Home app?

Yeah everything is fine in the Mi App… And all devices show as online in Openhab as well. Don’t know if it helps but the gateway luminance on all of the gateways is the same, doesn’t change even in night, and I cannot turn the lights on on the gateway from openhab - but I can in the Mi Home app

Hmm thats odd…
I wonder if you´re missing the Xiaomi Gateway (thing) or there is an error in it.
I have two Things for the Gateway. One is the actual gateway link to the binding/openHab. The other is the smart home gateway (it´s psycical the same device).

Yeah, exactly the same for me. These all worked perfectly until I went from openhab 2.2 to 2.3 I think. They are all online though, and all connected to a bridge. Its odd! I have a new gateway I have just bought so I am going to connect that to a new Mi Home account and then new installation of openhab - if I get the same issue I guess it must be router based issue? But again dont know how it would be showing up on Mi Home if the router was blocking the ports?

You mention that

“luminance on all of the gateways is the same”

, so I guess you have multiple gateways configured as master / slave? Did you try to go back to a basic one gateway, one sensor config? Does that work?

Sorry, not sure what you mean master/slave?

I’ve now used a brand new gateway, brand new openhabian install this morning. Adding gateway all goes fine, add the developer key, then add devices. Again, all show as online, all seems to be working, but go to “control” on PaperUI and again nothing is there, nothing being updated, and cannot control the gateway: