Xiaomi Robot Vacuum Binding

Yes, now I can login without any message, no verification required.
However I have shared the Vacuum Cleaner with my family and I was able to login with one of the other accounts…

Has anyone had success with the app_zoned_clean command?
I got the coordinates from the Flole app, it seems okay, however if I start the vacuum with this command, it start for around 10 sec and returns to the dock. “Zoned cleanup completed. Some unreached areas are not cleaned”.
In the Mi Home app the square is okay, but however it refreshes the map as soon as I start the vacuum, since it can’t move there!?

@marcel_verpaalen Did you tried this out? If yes, how it is working for you?


Ps.: As soon as I wrote this comment, I tried again, and it worked… I have tried it before several times, I don’t know what’s happened…

This binding is working with the xiaomi robot vacuum 1st gen and 2nd gen, right?

Little bit offtopic, but can someone help me a little bit? Which version would you prefer me to buy? 1nd or 2nd gen? And why? It´s my first robot vacuum.

Yes it is working with both models.

I would say that version 1 is enough. Version 2 is almost the double of the price of the version 1 and it has only small benefits.
The mopping feature is not so good, so you won’t use it anyway I think.
The only thing in my opinion which is better in version 2 is that it can climb higher carpets and it can detect carpet and adjust the suction power to a bigger level. So if you have a flat which has lots of carpets in it and that carpets are usually thick, then choose version 2. For me version 1 seems enough (I have some carpets too, but it can easily handle that). Keep in mind that if you have lots of small carpets which can be moved easily, it will stuck on that

Hello guys.
I’m totally new to Oh and i try to get around.
I managed at a newbie state to bind some of my smart home devices but i’m kinda stuck on this xiaomi vacuum binding.
I just can;t understand from where to retrieve the token,
Any help will be very appreciated.


@raz77 you need to install Mi Home version 5.0.19, then use the MiToolkit to extract the tokens

I was able to do it after a few hours of searching the Internet,( as u said with 5.0.19 version)
So from what i understand if u update the app you are losing the token.
Or is “embed” in the machine and not the app itself?

Thanks again JohnD

the key is stored in the vacuum and as far as i know is only changed when you change the wifi settings, so after you get your token you can upgrade the app

Thank you mueslee

Is there a way to send a RGB command to a Yeelight with this Binding?

Of course yes.
Have a look here : https://www.yeelight.com/download/Yeelight_Inter-Operation_Spec.pdf

Declare your thing as basic one :

Thing miio:basic:MyLight "My Light" [ host="192.168.x.x", token="put_here_your_token" ]

Then, use the item actions#commands :

String MyLight_ActionsCommands "Actions commands" {channel="miio:basic:MyLight:actions#commands"}

And send your command like this simple one :

sendCommand(MyLight_ActionsCommands, 'set_power["off", "smooth", 2000]')

If anything goes wrong, check the log before. In most of case, the issue is the token.

I was able to setup the zoned cleaning button with the Flole app.
However I have a weird problem with it. It works very well, I can see it in the app, how it selects the area when I press the button.
However sometimes the orientation of the map changes, that results in that the selected area becomes unreachable. Does anyone has similar issues with this?

Hello guys.
Me the neewb again.
I try to see the map on flole app but I get this weird error about enter the right credentials.
I’m a bit lost because I can control the vacuum with flole (wich means I’m connected )
Can someone help me on this?

Hi Marcel,
I’ve posted some data here from Xiaomi SmartMi Fan, It would be great if you include it in your binding. I’ve tested them as raw commands through “actions#commands” .

@daznik Yes, will do that, considering to buy this fan. How do you like it?
Can you send me the model you see in the config. As that is needed to make the entry in the database.

What is the model you see in the config? Is your device recognized as unsupported?

You could experiment to manually define it as a miio:basic thing and override the model string to yeelink.light.color1
This will allow you to send the color command

In the PaperUI it looks like this:

Do you mean the indentifier “Yeelight1-5” in the PaperUI?

okay, and for the device that you want to send the color command to…
if click the edit button you can see the model. You can also override it there

Oh, you mean the ModelID? interesting, but how do I send RGB values while runtime within the rules to them?

I see…
I never tried it, but I think there are 2 ways with rules:

  1. Send a raw command based on the spec @Orfait attached to the command channel
  2. Send a color command with rules. Color is bit of a pain,

you can try something like
var HSB_WARM_WHITE = new HSBType(new DecimalType(30), new PercentType(20), new PercentType(100))
sendcommand ( lightthing, HSB_WARM_WHITE)

1 Like