Xiaomi Robot Vacuum Binding

binding
vacuum
xiaomi
Tags: #<Tag:0x00007f212a786570> #<Tag:0x00007f212a786390> #<Tag:0x00007f212a786250>

(marcel) #719

It is a direct connection… The cloud is not used in this binding (hence no need for your Xiaomi userid/password)


(Ingo Liebig) #720

Oh wow! Okay, thats awesome. And, it’s the same for all products in this binding? I am really confused why some of my xiaomi ceiling lights have such a long delay or won’t react at all :S


(marcel) #721

yes, it is for all of them. Note that the devices themselves do communicate with the cloud.
You may try to switch on debugging (see first topic) to see if they are slowly responding, or give errors while communicating.


(MM) #722

Hi. This Binding is really working great. Thx for the good work and your Support. I got my new Yeelight ceiling 480 Yesterday but couldnt get it to work. I even tryed with your trick adding it as basic device using “ceiling1,…2,…3,…4” but got errors in openhab Log. Has someone this ceiling light running ?


(marcel) #723

I would try the following ones
philips.light.ceiling
yeelink.light.ceiling4
yeelink.light.color1
yeelink.light.lamp1

what sort of errors do you see in your log? I would expect the basics to work with any of these as the commands are the same for all current yeelights (e.g. on/off, brightness etc)


(Ondrej Horak) #724

Hi @marcel_verpaalen, I can test the string, but looks more like a option of carpetmode than the mop (separate setup items in Mi app).
Could you give me a hint how to send this command to via the openhab? Shall I set a switch item within sitemap linked to actionCommand?


(Ondrej Horak) #725

One set of strings do not work with my V2 Roborock. They all are related to the last cleaning (all .items & .sitemap more or less copy&paste of the code from the forum here). Is it only due to v2 robot?
See how it looks:


(MM) #726

Thank you. Must have been blind - looking in the miot.xml to get the token and there is written “yeelink.light.ceiling3”.
Thought, that I’ve already tried it and got errors … - now its working. Thx for pointing me in the right direction.


(marcel) #727

You need to link a string item to the command channel. Note that that channel is marked advanced so in paperui only visible if you use the show more

You can then send the command and the reply will be in the same channel.


(marcel) #728

Looks like it. Can you send me the debug log so I can see the full conversation and responses.


(marcel) #729

Let me know the one that works best, and your original model and I add it to the database


(Filip ) #730

how do I extract the token on android, all the successful guides above were made for ios users.thanks


(Tom) #731

You need an older version of the Xiaomi Android App.

It’s all in this post


(MM) #732

Is someone running this Binding on OH 2.4 Milestone build ?
I Updated from 2.3 to Milestone and the Mi io Binding is gone. Cant Install it from Papier ui or habmin because its missing in the add ons too. Any Idea ?


(Michael Joos) #733

@mr.mixx Please make sure you have installed the “Eclipse IoT Market” in Misc-Section and change the setting to “Alpha” under Configuration -> System.

If this doesn’t work:

You can download the jar-File directly from here and place it in the addons-Folder:


(John) #734

btw. If you can’t see the bindings from the Marketplace, there has been a problem with the Marketplace over the last few days.
There is a fix described in this thread.

https://community.openhab.org/search?q=Failed%20downloading%20Marketplace%20entries


[SOLVED] Eclipse IoT Marketplace Issue
(MM) #735

Thx for your Help @michaeljoos and @ John.
It was the Problem with the Marketplace. Following the instructions in the topic solved the Problem.


(Hans) #736

hey, could you add a working link please? your link brings me to the search page of openhab with a bunch of different topics, but not no a related problem solving help… many thanks!


(John) #737

Sorry try this


(Smhgit) #739

I have added th following thing to .things:

Thing miio:vacuum:0XXXXXXX “Xiaomi Robot Vaccum Cleaner” [ host=“192.168.0.xxx”, token=“xxxxxxxxxxxxxxxx” ]

Currently I am getting “Configuration Error”. The token i used worked for me, but now I have change to this binding, update the Mi Home App and updated the robot software. Might be that the token is no more valid?

Also,

Should I use miio:vacuum or miio:generic?

[Edited]

1. It was an issue with the token. I have extracted the token again and now it works
2. I use miio:vacuum and it seems to work fine

Thx for any help