Xiaomi Robot Vacuum Binding

binding
vacuum
xiaomi
Tags: #<Tag:0x00007fd30db46df0> #<Tag:0x00007fd30db46cb0> #<Tag:0x00007fd30db46b70>

(Peter Mueller) #550

Ok answered it myself…I made a backup of the token and deleted the cleaner in OpenHAB. Then, I tried to discover the cleaner, found it and inserted the saved token. Voila, cleaner available in OpenHAB again.


(Hallo Ween) #551

I have a yeelight light strip rgb. It is wokring with this binding.

Can i disbale internet access for this inside my router (so only lan connection is possible) or will this light strip stop working after that?

I can see many connections to xiaomi servers.


(Oliver Libutzki) #552

The first version of the vacuum cleaner supports zone cleaning since a couple of days. Any plans to extend the binding accordningly?

Here is a discussion for ioBroker (in German): https://forum.iobroker.net/viewtopic.php?p=138421


(marcel) #553

Yes, probably at some point when the coordinate stuff is better understood.
Note that you can obviously already use the command using the command channel


(Oliver Libutzki) #554

You talk about this? https://github.com/marcelrv/XiaomiRobotVacuumProtocol/blob/master/app_zoned_clean.md

Do you have an example how to execute such a command?


(Oliver Libutzki) #555

Ah, seems to be miio:vacuum:{thingId}:actions#commands


(marcel) #556

yes, indeed… might need bit of experimenting with the exact format.
based on the stuff I’ve seen I expect you need to send like app_zoned_clean[[26234,26042,27284,26642,2]]


(Jeremy Scott) #557

What is the status of this issue (the threading issue Xiaomi Robot Vacuum Binding) ? Is this being tracked in an issue somewhere.

I’d like to help if its not been fixed.

Thanks


(Mark) #558

It’s fixed in the latest version of the binding.

See discussion here and commit here


(Jeremy Scott) #559

super. great work.


(marcel) #560

Yes, it is fixed, thanks to @mhilbush!


(Tom Araya) #561

I got a new vacuum (version 1) and want to connect it to OH2 without going to the cloud, but I struggle to get the token.

My computer is connected to my ‘normal’ network via LAN to have access to OH2 and to the vacuum via WiFi. The binding is installed.

When I start the recovery, no vacuum is found by OH2.

What is my mistake?!

Thanks for help!


(marcel) #562

@Budo possibly try to ping your robot to ensure you have good connectivity to it.

note that getting the vacuum to work without cloud access is still somewhat tricky.
check out https://github.com/dgiese/dustcloud.git
It has an alternative cloud implementation. You would need to root your device for it, and it is still quite alpha status


(Matthias Dohr) #563

didnt try with zoned cleanup, but goto works

rule "test"
    when 
    Item test received command
    then 
    if (receivedCommand==ON){
    sendCommand(RoborockVacuumS5Miio74478323_ActionsCommands,"app_goto_target[20000,25000]" )
    }
end

(Tom Araya) #564

Thanks for the fast answer! I did not get it working without registering via app. Two Mi Robots are working like a charm.

Thanks for the great binding!


(Andy Wolff) #565

Hello,
i have a problem with the MiIoAsyncCommunication every 3 - 5 days.
Every 30 seconds i see this in the openhab.log

2018-04-26 18:17:46.430 [INFO ] [nal.transport.MiIoAsyncCommunication] - Received message is invalid JSON: 
2018-04-26 18:17:46.441 [INFO ] [nal.transport.MiIoAsyncCommunication] - Received message is invalid JSON: 
2018-04-26 18:17:46.451 [INFO ] [nal.transport.MiIoAsyncCommunication] - Received message is invalid JSON: 
2018-04-26 18:17:46.463 [INFO ] [nal.transport.MiIoAsyncCommunication] - Received message is invalid JSON: 
2018-04-26 18:18:16.525 [INFO ] [nal.transport.MiIoAsyncCommunication] - Received message is invalid JSON: 
2018-04-26 18:18:16.535 [INFO ] [nal.transport.MiIoAsyncCommunication] - Received message is invalid JSON: 
2018-04-26 18:18:16.544 [INFO ] [nal.transport.MiIoAsyncCommunication] - Received message is invalid JSON: 
2018-04-26 18:18:16.552 [INFO ] [nal.transport.MiIoAsyncCommunication] - Received message is invalid JSON: 

I can not see the current values from my vacuum robot…

When i restart openhab, the communication is ok again.

Does anyone have an idea?


(marcel) #566

Does it help to restart the xiaomi device that is causing this?
What you can try to do is to edit the vacuum settings (any change will do), or restart the binding itself.

If that does the trick somehow this can be narrowed down to the binding.
In that case, please change the log settings to debug to see the detailed communication. Maybe that tells some more
What version is your firmware ? What is the hardware you are running this on?


(Olov Frykerås) #567

Hello,
I had the binding working perfectly with my Roborock 2 but then I updated the firmware to 3.3.9_001228. Now I get Communication error. Is there anyone else having this trouble?
Thanks for a great binding


(Thomas Schwarz) #568

Hey Ellis,

thanks for the wrap up and special thanks to @marcel_verpaalen. I know the main language of the community is english. But maybe you are able to follow the german Tutorial on YouTube. I am going step by step through the integration of the yeelight. 30 Minutes :rofl:

Have a nice weekend.

Best regards
Thomas


(Thorsten G) #569

Hi everyone,

This rule works for zone cleanup:

rule "Staubi_Esstisch"
 when
    Item StaubiEsstisch received command
 then
  if (receivedCommand==ON) {                                              
   sendCommand(actionCommand,"app_zoned_clean[[26063,25178,28863,29278,1]]"
   Thread::sleep(10)
   StaubiEsstisch.postUpdate(OFF)
  }
end

You can use the latest build of the Flole app to get the coordinates for the desired zone!

https://xiaomi.flole.de

Best regards
Thorsten