Xiaomi Robot Vacuum Binding

binding
vacuum
xiaomi
Tags: #<Tag:0x00007fd30d1b7870> #<Tag:0x00007fd30d1b7730> #<Tag:0x00007fd30d1b75f0>

(Flole) #610

That probably means your account is not verified. Go to https://account.xiaomi.com, login and verify your email address.


(Kristof Rado) #611

Thanks! That could be one issue, because it was not verified. However, now it is verified, but I still can’t login, get the same error. Should I wait or it has any other issue?

Ps.: I had to verify again when I added the security questions. Thought this is the problem, but not, still gives the same error. Now my account is fully secure…


(Flole) #612

Have you logged in to account.xiaomi.com without getting a message about verification being required? The login should go through there without any problems, otherwise the import will be rejected by xiaomi.


(Daniel Linder) #613

Hi,
I don’t know if I am correct in this observation, but recently I’ve been unable to dim (change the brightness channel) on my two xiaomi bed side lamps, using the bindning (the dimming slider just pops back to the set value)
When I added the lamps (around x-mas time) i defined the brightness Items as “Dimmer” in my items file.
However, now the bidning detects the Brightness channel as “Number”.
I can of course adjust the brightness via number (it functions ok). However, it makes UI:s a bit aquard.

Below is how the lamp is currently detected.

Mi IO model yeelink.light.bslamp1 identified as: Yeelight Lamp (yeelink.light.bslamp1). Matches thingtype miio:basic.

Has something changed in the recogintion of channels?

(I am running OH 2.3.0 daily builds, and the corresponding MI IO bindning from the “market”)

Cheers
/Daniel


(Kristof Rado) #614

Yes, now I can login without any message, no verification required.
However I have shared the Vacuum Cleaner with my family and I was able to login with one of the other accounts…


(Kristof Rado) #615

Has anyone had success with the app_zoned_clean command?
I got the coordinates from the Flole app, it seems okay, however if I start the vacuum with this command, it start for around 10 sec and returns to the dock. “Zoned cleanup completed. Some unreached areas are not cleaned”.
In the Mi Home app the square is okay, but however it refreshes the map as soon as I start the vacuum, since it can’t move there!?

@marcel_verpaalen Did you tried this out? If yes, how it is working for you?

Thanks!

Ps.: As soon as I wrote this comment, I tried again, and it worked… I have tried it before several times, I don’t know what’s happened…


(Hallo Ween) #616

This binding is working with the xiaomi robot vacuum 1st gen and 2nd gen, right?

Little bit offtopic, but can someone help me a little bit? Which version would you prefer me to buy? 1nd or 2nd gen? And why? It´s my first robot vacuum.


(Kristof Rado) #617

Yes it is working with both models.

I would say that version 1 is enough. Version 2 is almost the double of the price of the version 1 and it has only small benefits.
The mopping feature is not so good, so you won’t use it anyway I think.
The only thing in my opinion which is better in version 2 is that it can climb higher carpets and it can detect carpet and adjust the suction power to a bigger level. So if you have a flat which has lots of carpets in it and that carpets are usually thick, then choose version 2. For me version 1 seems enough (I have some carpets too, but it can easily handle that). Keep in mind that if you have lots of small carpets which can be moved easily, it will stuck on that


(Turloiu Razvan) #618

Hello guys.
I’m totally new to Oh and i try to get around.
I managed at a newbie state to bind some of my smart home devices but i’m kinda stuck on this xiaomi vacuum binding.
I just can;t understand from where to retrieve the token,
Any help will be very appreciated.

Best


(JohnD) #619

@raz77 you need to install Mi Home version 5.0.19, then use the MiToolkit to extract the tokens


(Turloiu Razvan) #620

Thanks.
I was able to do it after a few hours of searching the Internet,( as u said with 5.0.19 version)
So from what i understand if u update the app you are losing the token.
Or is “embed” in the machine and not the app itself?

Thanks again JohnD


(Marcus K.) #621

the key is stored in the vacuum and as far as i know is only changed when you change the wifi settings, so after you get your token you can upgrade the app


(Turloiu Razvan) #622

Thank you mueslee


(JustAProgrammer) #623

Is there a way to send a RGB command to a Yeelight with this Binding?


(Albin) #624

Of course yes.
Have a look here : https://www.yeelight.com/download/Yeelight_Inter-Operation_Spec.pdf

Declare your thing as basic one :

Thing miio:basic:MyLight "My Light" [ host="192.168.x.x", token="put_here_your_token" ]

Then, use the item actions#commands :

String MyLight_ActionsCommands "Actions commands" {channel="miio:basic:MyLight:actions#commands"}

And send your command like this simple one :

sendCommand(MyLight_ActionsCommands, 'set_power["off", "smooth", 2000]')

If anything goes wrong, check the log before. In most of case, the issue is the token.


(Kristof Rado) #625

I was able to setup the zoned cleaning button with the Flole app.
However I have a weird problem with it. It works very well, I can see it in the app, how it selects the area when I press the button.
However sometimes the orientation of the map changes, that results in that the selected area becomes unreachable. Does anyone has similar issues with this?


(Turloiu Razvan) #626

Hello guys.
Me the neewb again.
I try to see the map on flole app but I get this weird error about enter the right credentials.
I’m a bit lost because I can control the vacuum with flole (wich means I’m connected )
Can someone help me on this?


(Nikita K) #627

Hi Marcel,
I’ve posted some data here from Xiaomi SmartMi Fan, It would be great if you include it in your binding. I’ve tested them as raw commands through “actions#commands” .


(marcel) #628

@daznik Yes, will do that, considering to buy this fan. How do you like it?
Can you send me the model you see in the config. As that is needed to make the entry in the database.


(marcel) #629

What is the model you see in the config? Is your device recognized as unsupported?

You could experiment to manually define it as a miio:basic thing and override the model string to yeelink.light.color1
This will allow you to send the color command