Xiomi (MI) Switch rule - nothing happens

Sorry then, I am out of ideas.
The only other things I would consider doing would be;

  • uninstall and reinstall the binding
  • Or, shutdown Openhab and clear the cache.
    I don’t really think either is your problem but they are sometimes my go to solutions when nothing else works.

Bummer… Appriciate your help! - I tried to uninstall/reinstall and clear the cache… I can see the log that the scheduler is started, and it read the xiomi.rules - and no errors…

I can see the sensors updated in PaperUI, and also the switch.
I can see the events in the MI App.
Firmware is updated.

sort of wierd… Perhaps I should try another rule… Have a simple one just to figure out if it is the scheduler that is broken?

btw, Just for clarity/comparison, my setup is;
Openhab 2.3 stable
The default Xiamo Mi Home binding that comes with that
The switch is the round Mijia Wireless Switch
The gateway I think is a v3

I’m pretty sure I had some troubles originally using the switch in a single rule which is why I split them but that was a long time ago now.

Same setup…

Even tried the next-gen rule setup. Same result.

The Xiaomi binding must be faulty on my setup… I will try to delete ALL devices on the gateway, reset everything - reinstall openhab, import the conf dir and try pairing again… (doh!)