Yeelight Binding missing in openHAB 2?

Good morning everybody,

I got a couple of xiaomi ceiling lights and had hoped to control them using the yeelight binding. However, that binding doesn’t even show up in the selection of bindings in openHAB2. I find this a little strange considering it is shown as one of the supported brands on the official openHAB page.

I am now using the Xiaomi IO Branding… but this only gives me the option to turn the lights on/off.

Was that binding removed?

Thanks in advance!

No, it is there. It’s pretty new so if you are on stable 2.3 it may not be available.
Snapshot 2.4:

Oh, yeah. I intalled openHABian (pi) last week …so I am probably on stable 2.3.
Is it “safe” to install it on latest openHABian (pi)? I’d like to give it a try. No idea how much work it is to update it manually later ^^,

Thanks for letting me know!

You can try installing it manually by dropping the snapshot jar into your addons folder:$org.openhab.binding.yeelight/

But if the binding needs changes in the runtime you may be out of luck.

1 Like

Thanks a lot. I might give it a try. Gonna backup my system and I should be save… I guess :smiley:

1 Like

Dropped it in the folder. Was detected. Doesn’t find any things ^^, No errors in the log either though

Did you go through the preconditions?

Yeah. I am using china mainland server though… could this be the problem?

Mybe there are conflicts with either the
Xiaomi Mi IO Binding
Xiaomi Mi Smart Home Binding ?

No, same here.

Don’t know, not using those.

So I am on openHAB 2.3.0 Release Build for the RPi 3… using the 2.4.0 SNAPSHOT of the Yeelight binding… I just dropped it into the openhab2-addons folder and rebooted the Pi… anything I did wrong? I got 3 Xiaomi Ceiling Lights and I enabled developer mode for all of em

No. But it still could be that a new 2.4 binding does not work with 2.3 stable because it needs the changes for the 2.4 runtime.
Last thing to try: check via karaf if the yeelight binding is active:

openhab> bundle:list|grep -i yee
234 │ Active   │  80 │     │ Yeelight Binding

I am actually quite new to openHAB and have no idea what karaf is and how I start it. I use putty to connect to my pi… but the command bundle:list is unknown

204 │ Active │ 80 │ │ Yeelight Binding

Yep, it is indeed active :confused:

I’m have the same problem right now. I wanted to add my yeelight ceiling light, had to upgrade to 2.4 to get the bindung but now autodiscovery wont work. Is there a wy to get the ID manually?

Any reason why using a pretty old version?

Isn’t that the version you linked earlier? If not then its another version I tried after I used yours… :frowning:

I installed the version you linked again… behaves the same. No things found :frowning:

Then I guess you need to upgrade to the 2.4 snapshot.

Hi guys I new to his all but I got 1: openhab 2.4 snapshot. 2: the yeelight Binding 3:LAN control on (it in side the yeelight APP)
What I don’t have is the Yeelight coming up in my inbox.
I can manually add it but I don’t know how to find the Device ID
Id of the Yeelight device to connect with.