Yeelight Ceiling light - No Connection since last Firmware Update


does anyone use the Yeelight Ceiling light?

I had it integrated into openhab until the last firmware upgrade. Since then i am not able to find it anymore.

Anyone experienced the same behaviour?

It would be helpful if you told us which binding are you using?
Is it the abandoned Yeelight binding that @coasterli once started?
Or the Miio Binding from @marcel_verpaalen?
If the second one, I’m not sure if you can use it without the token.

I’m still using the Yeelight binding because I struggled with getting the token from my unrooted Xiaomi phone :wink:

I’m using both bindings in my system. @coasterli for my yeelights and the Miio Binding for the vacuum.

Neither of them are finding my Ceiling light.

Steps i have already taken:
Reset of the Ceiling light
Removal of my Thing and Item definition
Ran the Discovery of both bindings

-> Ceiling lamp doesn’t appear again. My other RGB yeelights are still working

I am using the binding of @coasterli in my system.

Yeelight RGBs (FW 1.4.1_57) and Yeelight Stripe (FW 1.4.1_40) are found, Yeelight desk lamp (FW 1.3.0_52) and Yeelight Ceiling (FW 1.4.8_173) are not found.
I tried to add them manually, no success.
Has anyone succeeded in using Ceiling or desk lamp with the yeelight binding? Any hints are welcome!

My Yeelights will not go online.



Dimmer	WohnzimmerYeelight 					"Bright"				{channel="yeelight:Wonder:045652A6:Brightness"}
Color	WohnzimmerYeelightColor 			"Color"	<colorlight>	{channel="yeelight:Wonder:045652A6:Color"}
Dimmer	WohnzimmerYeelightColorTemperature	"Color temperature"		{channel="yeelight:Wonder:045652A6:Color_Temperature"}


sitemap default label="Wohnung" {
	Slider 		item=WohnzimmerYeelight 				label="Wohnzimmer Licht" 			icon="light"
	Colorpicker item=WohnzimmerYeelightColor 			label="Wohnzimmer Farbe" 			icon="colorwheel"
	Slider 		item=WohnzimmerYeelightColorTemperature label="Wohnzimmer Farbtemperatur" 	icon="light"

Since my update onto this version of the firmware I cant use the ceiling light anymore via the binding.
Now i control them via Command line scripts. If you are interested i can send you some links.

They appear to be offline, as long as they are OFF. After you turn them ON they normally appear as Online

They are online. Check the entry above. I set the same ID in the second row.

Maybe you can’t use the same channel twice?

If I select another ID how to forward information to the Bulb? On miio you have to put the token of the bulb but at yeelight binding.

I think you have to remove the thing from miio and just use it via yeelight binding.

The id is from the bulb itself, you cant change it

Well I need to enter the Token to control it. If I set only the Yeelight Binding than I cant set the token and there is no control over the bulb

You dont need a token with the yeelight binding.

AFAIK the two bindings are using different discovery methods. With the yeelight binding you just need to enable the lan control.

1 Like

@Simsal Simon

I am interested in the command line scripts, please post the links!
Many thanks!

Hey Martin,

you can find the yeelight cli here:

you need to specify the ip address of your lamps. It would be ideal if you can assign them a static address via your router, otherwise you have to change the ip address everytime your lamps get a new one assigned.

example usage:

rule "Yeelight an-/ausschalten"
            Item MotionStatus changed
            if(MotionStatus.state == OFF){
                    executeCommandLine("yee --ip= turn off")
            else if (MotionStatus.state == ON){
                        executeCommandLine("yee --ip= turn on")

Hallo Simon

Dankesehr/ Thanks a lot!

Can you give me a hint how to use the result of the rule in a switch?

I am currently using a switch like this:

Switch Yeelight4_Switch “Schreibtischlampe” (EG_Buero) {channel=“yeelight:Desklamp:0x00000000039cc1…:Brightness”}

I think it has to look somehow like this:

Switch Yeelight4_Switch “Schreibtischlampe” (EG_Buero) { yeelight=“” }


I can try.

Please show the rules and also the relevant part of the logfile.

try this:

rule “Yeelight”

        Item test changed
        if(test.state == OFF){
                executeCommandLine("yee --ip= turn on")
        else {
                    executeCommandLine("yee --ip= turn off")

Haa… interesting…

good you got it to work. I still would recommend to switch over to the mi io binding.

It is much more reliable.

Yeelight is in alpha support in the mi io binding.
Basic functions work, some may not. Your mileage may vary per model. Basic functions like on-off brightness etc will most likely work.

Mi io binding does not require a bridge.
You need to install the binding via the market place.