Z-Stick Gen 5 not including devices

I connected a new Z-Stick Gen5 (well, bought a while back; just now getting around to hooking it up) to a new (really brand new) RPI 4 running openHabian. I added the Z-Wave Serial Controller bridge, which looks like it was successful (it shows online).

However, it does not find any devices when searching. I have two unattached devices that it should find. These show up on OH2’s inbox when I scan there.

Interestingly, when i added the Z-Stick, it the USB port wasn’t named with “USB” in the name, as many googled posts intimate it should. I endeavored to make sure I was selecting the right port from the dropdown by doing the following (and this doesn’t imply I understand the shell, just that I can google and infer):

auzick@openhabian:~ $ for sysdevpath in $(find /sys/bus/usb/devices/usb*/ -name dev); do
>     (
>         syspath="${sysdevpath%/dev}"
>         devname="$(udevadm info -q name -p $syspath)"
>         [[ "$devname" == "bus/"* ]] && exit
>         eval "$(udevadm info -q property --export -p $syspath)"
>         [[ -z "$ID_SERIAL" ]] && exit
>         echo "/dev/$devname - $ID_SERIAL"
>     )
> done
/dev/ttyACM0 - 0658_0200
auzick@openhabian:~ $ lsusb
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 015: ID 0658:0200 Sigma Designs, Inc. Aeotec Z-Stick Gen5 (ZW090) - UZB
Bus 001 Device 002: ID 2109:3431 VIA Labs, Inc. Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Note that the output from the first command is /dev/ttyACM0 - 0658_0200 and the lsub says that 0658:0100 is the Aeotec Z-Stick Gen5. Assuming I’m reading all that right.

I mention all that just to cover an anomaly I noticed when setting up the Z-Stick; the gist of my post is really about not being able to add z-wave devices.


Please be aware that ZWave is based on dedicated networks that have unique IDs. Including a device into a network means, this device will no longer answer to messages of another network.

The fact your two devices are shown in the inbox of OH2 (which runs with another controller I assume) indicates that they are included into the network the other controller manages. Without excluding them from the other controller and including them into the network of your new Z-Stick they will never show up in your RPI 4 inbox.

As far as I know there is a possibility to include a second controller into an existing network but I did not experiment with such a setup, hence do not know about what might be possible in such a setup.

Thanks @stefan.oh

I guess I misunderstood the nature of the inbox. I thought that items in the inbox has been seen on the network but not yet joined to the controller. So I guess an item in the inbox has joined to the controller but not yet added as a thing?

One of the items I’m trying to join has been explicitly removed from the old stick. I assumed it worked because the associated item stopped responding was showing back up in the inbox.

I need to keep the old oh2 setup running while I do a fresh start on oh3 on separate hardware.

Correct :slight_smile:
“joined the controller” means it has been included into the Z-Wave network and thus is known to the Z-Wave controller. That is a rerequisite to be shown in the inbox. Only then can it be defined as a “thing” in the OH-world

Understood. Old assumptions biting me again.

I’m not finding a good way to reliably turn off autodiscovery in oh2. Guess I’ll have to be quick about it as I exclude from old / include in new. I really want to keep the oh2 box running throughout what I expect will be a slow process. Luckily many of the devices are GE switches have have an easy reset sequence, so I can just walk up with the new Z-Stick gen5 and move them over quickly.

Thanks for taking the time to help!

Autodiscovery should not bug you at all: as you are working with two different Z-Wave controllers and a Z-Wave device can only be included in one Z-Wave network at any given time, your devices should either appear in one installation exclusive-or in the other. Never in both. If this is not the case the exclusion process failed, most likely leaving zombie nodes in your OH2 installation.

When I moved from OH2 to OH3 I did a complete new setup (similar to your case), copied over the setup (openhab-cli backup/restore), did the necessary changes (mostly datetime stuff) and tested everything without the Z-Wave stuff. The OH2 system was still in place and had the Z-Wave controller connected. Only when I was satisfied that everything looked fine in the new installation, I switched the Z-Wave controller over to the new installation, scanned for Z-Wave devices and set them up in the same way as in the old OH2 system. It took me app. 1h to do that and I had a working OH3 system (23 Z-Wave devices). Checking the configuration parameters for each device followed after that, but the real downtime for the switch was app. 1 hour that way.

Caution: If you included some devices securely, you need to transfer the security key from OH2 to OH3 as it sits in the OH configuration, not on the Z-Wave controller.

Thanks @stefan.oh

I haven’t had much success in excluding things from the old OH gear and then joining them to the new (and yes, 2 and 3 are on separate hardware and separate controllers). Not sure if the exclude function on habmin isn’t working as I expected, or oh2 is immediately adding it back to the inbox. So far I’ve just been doing a forced reset on the device and then adding them to the new stick (aeon gen 5, which is handy because I can just carry it to the installed device). I’m aware I’m leaving zombies behind, but I’m planning to completely retire the old installation when I’m done.

Appreciate the reponses!