Z-Stick Gen5

I’m trying to get my Aeotec z-stick Gen 5 to work with OpenHAB and I’m not having any success getting the devices I’ve paired to show up in HABmin.

I paired 2 of my Fibaro sensors to the z-wave stick. I verified the sensors successfully paired using the Aeotec IMA tool.

I determined that the z-wave stick is ttyACM0 when plugged into my RPi3.

I’ve edited the openhab.cfg z-wave Binding to zwave:port=/dev/ttyACM0

I ran sudo usermod -a -G dialout openhab in the terminal window.

I added the text below to my home.items file:
Number Movement “Movement: [%s]” { zwave=“3:command=sensor_binary” }
Number Alarm “Alarm: [%s]” { zwave=“3:command=sensor_alarm” }
Number Lux “Lux: [%.2f Lux]” { zwave=“3:command=sensor_multilevel,sensor_type=3” }
Number Bat “Battery: [%d %%]” { zwave=“3:command=battery” }
Number Temp “Temperature: [%.1f °C]” { zwave=“3:command=sensor_multilevel,sensor_type=1” }

I restarted openhab.

I open up HABmin (version 0.1.4), select “Configuration”, “Bindings”. I see 2 z-wave Bindings, one is version and the other is version 1.8.3.

Neither one of them has any values in “Devices”.

That is mostly your problem, remove the old 1.8.0 binding, keep the 1.8.3 binding (or even upgrade to the snapshot 1.9.0).
You cannot have two zwave bindings in place …

How do I delete the old binding? Do I just delete the .jar file?


Thank you SO much for your help! This is the second time you have solved my OpenHAB problem! I really appreciate it. :slight_smile: