Z-Stick in OpenHAB2

I try to get the Z-Stick working with OpenHAB2. But I receive this error…

17:59:16.000 [INFO ] [me.event.ThingStatusInfoChangedEvent] - ‘zwave:serial_zstick:1cacff0d’ changed from OFFLINE to OFFLINE (COMMUNICATION_ERROR): Serial Error: Port /dev/ttyACM0 does not exist

Can anybody help me to get this working?

The error message is pretty self explanatory - the binding thinks the port doesn’t exist. If you’re sure it does exist, then maybe the user that you’re running under doesn’t have permission to access it?

1 Like


export EXTRA_JAVA_OPTS=-Dgnu.io.rxtx.SerialPorts=/dev/ttyACM0

to karaf in ./runtime/karaf/bin fixed my problem.

1 Like


I have the same problem and you basically gave the solution. Now for my rookie question: is it just to run this command?, or how do I get it into ./runtime/karaf/bin?

Thanks for taking the time to reply.

I included it in the karaf script at the beginning. It works :slight_smile:

If you want to enter multiple serial ports, just separate them by using “:”

1 Like

Thanks man!

1 Like

Same problem, did alter karaf script as mentioned above (took me some time to find it), but still get the meassage:
“Serial Error: Port /dev/ttyACM0 does not exist”. Maybe some access problems for the port?

I’ve set up a fresh system on a Raspberry Pi 2, using a Z-Wave USB stick on /dev/ttyACM0. OpenHAB2 latest beta installed from package as online version. Right after the fresh installation I’ve installed the Z-Wave binding and it seems that the USB Stick is recognized “Z-Wave USB Stick with Serial Interface”.

So this also worked for me getting my zwave stick working. My question is why. Does it have to do with permissions? I’m using the apt-get install of openhab2 for the first time and finding a lot more troubles due to permissions. I’ve never had this issue previously.

My frustration is that it’s yet another place i have to modify things - and remember to - on any update.

1 Like

The full path for an apt-get install is /usr/share/openhab2/runtime/bin/karaf