Z-Stick no longer lets me include or exclude devices

I got stuck last night with the migration of my Z-Wave devices to openHab.

I started out with the Zipabox as the primary controller and added a Z-Stick, used in openHab, as the secondary. Yesterday I tried to turn the Z-Stick into the primary. I excluded all of the devices from the Zipabox, including the Z-Stick itself, then inspected the Z-Stick in the Z-Wave PC Controller (aka ZenSys tool). To my surprise, it reported the Z-Stick as being the primary, so I didn’t reset it as I had planned. I started re-including all the devices on the Z-Stick until I had just two left which didn’t seem to respond when trying to include them. I focused on setting up the things for the included devices, and then went back to try and include the remaining ones. Now, suddenly, the Z-Stick refused to include anything: instead of a flashing blue light, the blue light flashes once and then an orange light flashes, and that’s it. The same thing happens when trying to exclude a device - you get the orange light and then nothing. Inspecting the Z-Stick in Z-Wave PC Controller, I see that it now says “Network role: SUC, secondary”. I must have done something, but I have no idea what.

Is there a way out of this that doesn’t involve resetting the Z-Stick and adding all my devices again? I looked up what “SUC” meant, and apparently the controller with the role of “SUC” has the ability to grant primary privileges to secondary controllers. I have no idea how you do that, though.

I have tried including by pulling out the Z-Stick, and also by going to the inbox, plus sign, and Z-Wave binding to set the controller in inclusion mode that way. With the latter method, no lights appear on the Z-Stick, but nothing seems to happen when I try to include a device.

I don’t quite see a way out here, but apparently having a SUC isn’t enough to grant the primary role to a secondary controller, you need a SIS, and only the primary can be set as a SIS:


What I can’t fathom is how the Z-Stick was primary and then suddenly reverted to secondary. I added 26 devices with no problem and then the door slammed shut.

I think I’m looking at a reset. If you back up the nodes with the Gen5 backup tool, I don’t suppose there’s a way to restore them after you’ve reset and modified the role of the Z-Stick to primary?

Incidentally, the supposed primary controller is nowhere to be seen in the Z-Wave PC Controller. There’s just the Z-Stick, node 1. I can yank the power cord out of the Zipabox and everything carries on working.

Basically, there is no such thing as a secondary controller without a corresponding primary controller. Is one of your ‘remaining devices’ a controller? Maybe one of your ‘remaining devices’ is the primary controller now. If there is no SIS (Static ID Server) in your Z-Wave network, secondary controllers (e.g. your Z-Stick) cannot include devices.

I’ll get a screenshot of what I see in Z-Wave PC Controller. I’m pretty sure there’s only one entry in the “controllers” section. Presumably none of the devices in the “slaves” list can be controllers?

I’ll check and get back to you.

All the slave nodes are the devices I added. And apparently there’s just one controller. The Zipabox is turned off right now, but even if I turn it on it doesn’t appear in the network.

The ‘remaining ones’ aren’t in the list, right? Could one of the two remaining devices be the primary controller? AFAIK, even a battery operated device can be a primary controller …

Nope. One is a Fibaro flood sensor (battery-operated), and the other a Fibaro wall plug. Could they be controllers?!

Could they somehow inherit the primary controller role by default if the primary disappears? I could try unplugging the Fibaro plug and see what happens.

I tried it (unplugging the Fibaro). No change.

I found something anomalous. The Z-Wave Serial Controller thing, which I haven’t deleted and re-added, still says that the Z-Stick node ID is 68, which is no longer true. That was its old ID when it was the secondary to the Zipabox. I’ll delete it and try adding it again.

I think this issue is definitely related to the former use of the stick (being a secondary controller) Sorry if you already mentioned, what is the brand/model of the stick?

sounds like a good idea.

Aeon Labs (Aeotec) Z-Stick Gen5

Deleting the Z-Stick serial controller and re-adding it changes the ID of the thing, so now I have to add all the Z-Wave devices again (they all reappeared in my inbox). I’m concerned that I’m going to add them all again, only to come up against the same problem and have to repeat the operation for a third time, having this time factory-reset the stick. Quite likely. Ah well, in the name of science…

did the controller come up as node 1?

ahh… that is a concern. See if they are actually working first, they may have been (should be) assigned the same UID and work, in which case mark the ones in your inbox as ignore and carry on.

The zwave_nodeid from the information section is no longer there in openHab. None of those properties are. It just says SIS node 1.

Trouble is, if I have to reset the Z-Stick, and I can’t exclude devices, I’ll presumably have to factory-reset every device…? Is there another way?

The original devices now all show ERROR:Handler after deleting and re-adding the Z-Stick, because of the UID change.
Nearly finished adding the new ones…

1 Like

OK everything’s online again. The Aeon Z-Stick Z-Wave controller thing no longer appears as a device (having deleted the old one with the old UID), but it didn’t seem to do anything.

The Z-Wave PC Controller still shows the Z-Stick as secondary.

It looks like you are well into it, so this may not help. When you first create the bridge (plus, zwave,manual-Bridge) you can edit the UID to use the previous value.

Also you should include the devices while the Zstick is connected to OH, but I don’t think that is contributing to you issues.


1 Like