Z-Stick no longer lets me include or exclude devices

I’ll report back with whatever Aeotec tell me.

What it means is the controller is ready to exclude devices.

Once exclude devices is set you have 30 seconds (maybe 60- I’d have to check) to execute the exclude procedure on the device as found in the manual (i.e. press some button 3 times quickly). If it all works the UI page for the device should show offline “Device excluded by controller”. Then simply delete the thing. If that is not working for you it is probably related to the secondary controller issue.

I have always found Aeotec support very helpful. I’ll second that recommendation.



As I feared, Aeotec had no new suggestions. That means factory-resetting everything. It also means I’m going to lose a Duwi wall socket, since they appear to be impossible to reset - no great loss actually, since it was always extremely flaky, along with the others I used to have.

My 3am brain the other day failed to appreciate that choosing the thing ID on adding the Z-Stick essentially means you can keep all the existing Z-Wave things rather than deleting and re-adding them, or at least that’s what I suspect. If the ID is the same, and you maintain the same order, so that the nodes are the same, presumably each thing ID will be identical (this would imply plugging the gap in the nodes to replace the Duwi. Fortunately I have a new device for that). I’m not sure whether there might be some other bad consequences.

I had considered trying to create file-based thing definitions that I can easily modify, but that seems to be rather ambitious, or maybe impossible, for Z-Wave devices. I’ll stick to the UI for now.

1 Like

Last night I set about trying to reset all my Z-Wave devices (and the Z-Stick). I tried to maintain the order in which I added the nodes, to avoid having to reconfigure the devices in openHab. With many devices, there’s very little or no feedback to tell you whether the reset has worked, so you’re pretty much flying blind there. Then I tried to add them all again, fully expecting problems. And there were problems, lots of them.

The SIR-321 RF Countdown Timer was the first device I tried to add, since it was node 2. I can’t really say what was wrong, or what worked. I tried resetting it, adding it and excluding it numerous times until I finally managed to get it included, as node 3. One thing I learned: once a node is used, it can’t be “reused” until you do a “replace” in the control software. The new node IDs start from the maximum ID used at any point since you reset the controller.

The Aeotec multisensors, Qubino smart meter and Fibaro sockets didn’t really give me problems. They were straightforward to reset and include.

The Fibaro flood sensors are a little trickier since they’re battery-powered. Sometimes they get included in an incoherent state where certain channels never update, or you can never modify configuration parameters because every time you click save they are immediately replaced by the defaults (no matter how many times you press the TMP button you never see “pending” and the new values are never saved). In a few cases I had to reset the devices again and add them again.

The single Düwi socket I still had did not have a reset procedure. They apparently hadn’t thought of it. It was always a horribly unreliable device, turning itself off at random like the other two I used to have. Good riddance. I already had a Fibaro as replacement.

The three TKB sockets were a headache. The official reset procedure from the manual (Press on/off button 3 times within 1.5 seconds; within 5 seconds, press on/off button again for 1 second until LED is off) doesn’t work. What works is doing the exclude procedure, even if it’s a new network where the sockets were never added. I was ready to throw them all away until I found the post explaining this.

The nightmare: the Fibaro FGS 222 relay switches. The official procedure is to reset by holding the B button for 3 sec. after connecting the mains voltage to the switch (implying that you’ve cut the power previously). During all the tests I did, once one of them seemed to get included without even doing the include procedure after cutting the power, but since I didn’t know which of the two it was, I removed it again. After that I failed utterly to include either of them. I tried every reset procedure I found online, including pressing the B button for 3 seconds, then cutting the power, then pressing it again (maybe?). The consensus seems to be that you need to cut the power, then press the B button as the power is restored (i.e. it requires two people). I can’t get anything to work. Since I also failed to attach physical switches to the relays to operate them manually when I have problems like this, I’m seriously considering throwing them away and buying something else. But I don’t know what. They control the heating and cooling, so this is no trivial matter. Fortunately I still have a gas boiler I can switch to in the cold weather.

All the rest I managed to add, most of them with the same nodes.

1 Like

I did not read your full nightmare …

Concerning inclusion of the FGS I struggled also a lot.
I found in the manual that the FGS needs a direct connection to the controller during inclusion.
If the FGS has no solid connection it will fail often.
I took a cable with plug and included directly at the controller.
In final position you have to wait until it finds its way through the mesh to the controller.
They are working then fine.

1 Like

I took the Z-Stick and put it right next to the relays. Isn’t that enough :thinking:?

I actually gave up yesterday and ordered two FGS-223 relays. They’re a newer model so with luck they’ll be easier to include, reset, etc.

I have a RaZberry, so no chance to get it to the device.
I think to put the controller to the device is not recommended.
I remember Chris mentioned that this should be avoided.
But I could be wrong.

I have also a newer 223 which is in a room next to the controller.
It came up in inbox very quick and does its job since then.
Good luck!

1 Like

Same here. I’m not sure I understand what a direct connection would be.

I think you have a Z-Stick (USB)?
The RaZberry is a hat for the RPi.
The “Z” is not a typo :wink:

Ahh! Yes, I have a Z-Stick.