Z-TRM2fx device database update

Sorry about the lack of response here.

I just had a look - the non-multichannel association groups should be fine - I think that’s what is in the database now (although there are 5 groups in the database, and only 4 listed in the manual, so this should be checked).

Depending on exactly how this device works, there is a small chance that we may have some problems with reports. This is a pretty messy area of ZWave that has evolved relatively quickly and there are multiple definitions in the ZWave standards, and even more ways of implementing it! Currently the binding / database doesn’t support associations in endpoints other than the root, so if there is a problem, then I will need to look at this - so far though all devices have been configurable through the root association groups, so hopefully we’ll be ok here as well :slight_smile:

So, bottom line - make sure the groups are configured as per the non-multichannel definitions and let’s see if there are any issues, and also let’s see what channels are the ones that report.

Let me know how it goes…


Sorry for a week without any updates…

I updated the associations according to manual now.
I left the endpoints unchanged, except from adding label to distinguish which sensor is floor and air. I guess the rest of the data under endpoints are automatically generated from the zwave .xml file?

Once a new version is built with this included I can test it here. My understanding is that this is done using a .jar built from the development branch, is this available from some CI server? I could not find the link.

I believe the development branch of the Z-wave binding is terminated. It now goes straight into the SNAPSHOT.
Right @chris ?

I’m not sure if this got added before the system went down or if it’s waiting in the current PR - hopefully the CI will get resolved some time soon…

I checked the snapshot 2.50 from this Weekend.

Device is identifizied correct, Parameters all looks fine.

But there are problems with the channels.

Some of them are double with Same values, others had been working with older Profile missed now.

Except switch, Temperature2 and three: the Rest is Shown double.

Set_points for cooling, heating and ecoheating don‘t get new values when changed at Device.

Don’t know if there are further now missed.

Hope this helps with Development. I‘ll Check Everest Update of you want me to do :wink:

I don’t see any duplicate channels in the database - can you provide more information about what is duplicated (maybe a screenshot).

Sorry for my terrible english:)

not the channels my name are duplicated, Bit the values allways the same.

Example node2:meter_voltage Shows voltage of powersupply from the Device itself. Works fine.

node2:meter_kwh4 shows same value, should Show the usage of Electric heating, not the voltage(!!!) of the Device.

thermostat_mode Could ne only set one, there is a thermostat_mode1 allways the same.

thermostat_setpoint_cooling and thermostat_setpoint_heating Shows correct values, thermostat_setpoint_cooling1 and thermostat_setpoint_heating1 not needed and actual empty.
thermostat_setpoint_furnace should Show Economy setpoint?!? Allways empty, same with thermostat_setpoint_furnace1

You need to link the correct channel to your item.

If not needed delete them.

Are you using Simple mode? That means your items are automatically added and you don’t have any control over them.
It is recommended to disable Simple Mode and add your items manually, either through PaperUI or items text files.

I only tried simple Mode to get a fast way to show alle database channels. I know, i can configure them, the reason for post is some Else:

A Channel named kwh should not Show voltage values.

Of a device has got two usage measures (Device and switched Power behind Device) should Show both values.

You don’t need Simple Mode for that: add a Thing from your Inbox and all available channels are shown.

The database looks correct to me:


The device was updated four days ago, make sure you are using the latest zwave snapshot binding.

I Downloaded Snapshot at the Weekend, will try the Next days the last one.

Maybe it hat been changed day after my Snapshot.

Latest .jar Snapshot i found is 14 days old :confused:

I just tried updating to snapshot myself using the standard ubuntu package repository, and as @JensH experiences the binding is not up to date with the device database. I think we should hold it for a few days until snapshot is newer. (Is it possible to see plugin version from UI or terminal?)

I have to add that I am no expert in ZWave database, just tried to add things according to the documentation from Thermofloor/Heatit. My understanding was that the endpoints got automatically generated from the .xml file, but I may be wrong, and do not either understand why this device has so many unnecessary endpoints. Would it be correct to delete them from the database?

Based on feedback I guess we have the following “Issues” not yet resolved, that need to be verified in newer snapshot:

  • Unneccessary and/or incorrect channels.
  • Setting setpoint on device is not reflected in controller. (Maybe a association is needed)

At least, as far as I can see the config parameters are working ok.

Yes - it is. It was exported this morning, so all changes are currently integrated.

Please be more specific than this as it’s hard to help otherwise.

bundle:list | grep ZW* through karaf console

1 Like

Why do you say the endpoints are unnecessary? The manual does say they exist.

For instance I have “Setpoint (heating)” and “Setpoint (heating) 1”, and I cannot see any reason for this device to have two setpoints.

But I think we should wait for my ubuntu snapshot repository (mirror) to have a newer version of this binding before we debug further.

Ok, fair point, and I agree we should remove this sort of thing. My expectation though is that we will likely need to remove the one of the root endpoint and keep the one in endpoint 1. Let’s see.

I checked Build 20190123 now.

Device is recognized correct, options looking good, Temperature2 and Temperature3 working correct.

Some channels came immediately, but after 10 hours still empty. Over night there came all channels with 4 at the end again, all again double. kwh4 still showes the voltage